• Resolved aliceonfire

    (@aliceonfire)


    Inserting images from the WP media library is currently not possible with WP Editor activated. I don’t know if this is the same issue brought up by Li-An over 7 months ago and marked as resolved.

    The “Add Media” button allowed me to select and modify an image, but only the caption was inserted with WP Editor active.

    Perhaps connected problem: I then deactivated WP Editor and successfully inserted an image with alt and caption intact. Upon saving the draft and then reactivating WP Editor, the image insertion was gone from the drafted post as if it was never there.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author JaxsonWang

    (@jaxsonwang)

    Sorry to see the news here, I think ver5.0 to solve your problem

    I tried adding an image using the Add Media button while using the new version 5 WP Editor.md update, but it still doesn’t work. It is a very strange bug or conflict having to do with WordPress image caption shortcodes.

    If I fill in the caption field, the caption shortcode and text get put into the post without the image or link.

    If I leave the caption field empty, the image gets put into the post with the link (all in Markdown format).

    If I insert an image without a caption and then add the caption shortcode and text by hand, the Markdown within the caption shortcodes does not get parsed.

    Would it be possible to allow the option of not having images put into the articles using Markdown in order to allow for WordPress to auto-resize, add captions, etc?

    Plugin Author JaxsonWang

    (@jaxsonwang)

    Oh, this is really a big problem. Thanks for your feedback, I will solve it!

    https://github.com/JaxsonWang/WP-Editor.md/issues/141

    Hey Jaxson! I noticed this was fixed a while ago, but forgot to come here to thank you and close this support thread. Thank you very much for your continuing efforts!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Media Library Bug’ is closed to new replies.