Support » Fixing WordPress » Media Library Blank (Empty)

  • Hi!

    When i click to send image in post, the popup open but not show the thumbnails of images.

    But if i go to menu media, shows everything ok.
    The problem is in popup to send image, the media library there dont show the thumbs.

    Whats the problem? :/

    i reinstall wordpress manual and automatic and nothing changes…

Viewing 15 replies - 1 through 15 (of 16 total)
  • esmi


    Forum Moderator

    Have you tried:

    – deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the default theme to rule out any theme-specific problems.

    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    I have the same problem with my WordPress 3.5.1. I have all my pictures in my library but when I try to add media in a post or on a page the media library tab is blank.
    the first screenshot is the blank media library
    the second is an error that pops up if I try to upload a new image

    Orin is the same problem! But here, i can send the images! I cant see the thumbs in media gallery like your first screenshot…

    Same here. Having just a blank page and no error is not very helpful.

    I did a workaround:

    rename /wp-includes/js/media-views.min.js
    to /wp-includes/js/media-views.min.js.old

    Now the system is loading a old-ugly-version of media library but now it show all images and it is possible to “Set feature image”.

    Client is happy for now.

    Resolved my issue (blank media library).


    1 – Set WP_DEBUG as TRUE on wp-config.php;
    2 – Resolve any “Notice: Undefined index” kind-of-issue
    3 – Done!

    I set WP_DEBUG to TRUE, but don’t get any Undefined Index issues.

    One plugin had a warning so I disabled it, but I still get an empty media gallery when trying to select from the gallery to choose an image for the site header.

    I noticed that when I go to the “add new” screen under Media, I get the following error with WP_DEBUG on:
    Warning: fopen(http://[my site]/wordpress/wp-cron.php?doing_wp_cron=1363824890.7977209091186523437500): failed to open stream: HTTP request failed! in /[my site]/wordpress/wp-includes/class-http.php on line 921

    I got this to work for myself. If you’re lucky this applies to you to. 🙂

    My problem was that I had put some script includes at the top of my functions.php file. That’s it.

    There were no error or warning messages of any kind that told me I had a problem, I just had to use the old school binary-yank-until-things-worked method.

    This fixed both my issues with the media library and my “recent” links list being empty problem.

    Don’t know whether to be embarrassed for missing that or proud I found it (probably both). Hope this helps someone else out there!

    I resolved this issue by fixing my functions.php in my theme. I had several opening and closing PHP tags, and I think there may have been some whitespace outside of the PHP tags (there was also an HTML comment outside of them).

    Try making sure its a single PHP block with no whitespace or other content outside of it.

    I had the same issue.

    In brief, I uploaded pics in my post, I save as draft or publish it and then when i’ll come back on the same post, when I click to open the media library for this post, the pics have disappeared.

    I found that it was a problem with the theme I was using. It was related to ‘pre_get_posts’ filter.

    The original code was like this:

    and I added attachments by replacing this line:

    $post_type = array(‘post’);

    with this one:

    $post_type = array(‘post’,’attachment’);

    Hope this will help someone.

    It’s incredible but for me the problem was a plugin called “remove-tools-menu”.


    on my functions.php site i had ?> at the very end

    Apparently you should not close your <?php that’s opened on the first line

    I had the Media Features plug-in installed in an attempt to fix a different problem, and once I disabled that my thumbnails were restored. But I think it’s nuts how many ways this could get broken!

    I had the same problem and actually kind of lucked out. After upgrading WP itself, I also had to update my theme. Once I made that update the library worked as it should.

    I wonder if you change themes and then change back will help resolve the issue. Perhaps uninstall the theme (provided you haven’t made many customizations) and then reinstalling will also work.

    Good luck!

    Had the same problem, thanks to your hints I found the problem.

    I’d added Google Analytics tracking code at the bottom of my functions.php and getting rid of them restore my media library when editing posts and pages.

    Thanks everyone

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Media Library Blank (Empty)’ is closed to new replies.