Support » Fixing WordPress » Media-Library blank because of 403

  • Resolved insanitydesign

    (@insanitydesign)


    Hi everyone,

    maybe someone encountered a similar issue and might be able to help.

    When accessing the media-library no images are loaded. Every image triggers a 403, Access Denied.

    I searched for answers and found several:
    * I removed my .htaccess completely, to rule that out
    * I deactivated all plugins, to rule that out
    * I changed permissions to 755/644 for all content

    Still, the media triggers a 403 when loading in the library.
    Accessing the same URL directly, for example https://insanitydesign.com/wp/wp-content/uploads/2017/02/MarkdownViewerPlusPlus-Options-300×156.png works fine. The same one fires a 403 in the library.

    I am aware this might be an issue with Apache, PHP and Debian and with user rights. But the user is all the same for the whole directory and the user is related to the www-data group.

    All solutions I googled did not help. Maybe someone is able to point me in the right direction.

    Thanks a lot in advance

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Tim Nash

    (@tnash)

    Spam hunter

    When you try to upload a new image to the media library are you able to successfully see it?
    Or does this error?

    Hi there

    Same. The new picture also doesn’t show.

    I dug a little deeper, and it seems it is SSL related, that the “process” is denied maybe… but am not really sure.

    Thanks

    Hey

    Ok, I made an error but still do not know how to solve.

    I changed my whole site to SSL. All works fine for the site itself. Images are loaded in the normal posts. But as soon as Really Easy SSL Plugin or Insecure Content Fixer Plugin are enabled site still works fine but media library is broken.

    Disable, works. Enable, broken.

    Damn, what did I do wrong ^^#

    insanitydesign

    (@insanitydesign)

    Found my own error:
    There was not only a .htaccess in the root but also in the media/ folder, where the http(s) was missing. I only replaced/edited the root .htaccess as I didn’t check the sub-folder.

    Damn me ^^

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Media-Library blank because of 403’ is closed to new replies.