Support » Plugin: Media Library Assistant » Media Library Assistant : php 7 compatibility

  • Resolved sylvsteph

    (@sylvsteph)


    Hello,

    With PHP compatibility Checker :

    Media Library Assistant
    Not PHP 7.0 compatible.

    FILE: /home/clients/8dcbb407d8712de8af524ea86233eee6/web/wp-content/plugins/media-library-assistant/includes/class-mla-shortcode-support.php
    ——————————————————————————————————————————————–
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ——————————————————————————————————————————————–
    85 | WARNING | INI directive ‘safe_mode’ is deprecated from PHP 5.3 and forbidden from PHP 5.4.
    ——————————————————————————————————————————————–

    FILE: /home/clients/8dcbb407d8712de8af524ea86233eee6/web/wp-content/plugins/media-library-assistant/includes/class-mla-image-processor.php
    ——————————————————————————————————————————————
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ——————————————————————————————————————————————
    103 | WARNING | INI directive ‘safe_mode’ is deprecated from PHP 5.3 and forbidden from PHP 5.4.
    ——————————————————————————————————————————————

    FILE: /home/clients/8dcbb407d8712de8af524ea86233eee6/web/wp-content/plugins/media-library-assistant/includes/class-mla-data-pdf.php
    ———————————————————————————————————————————–
    FOUND 1 ERROR AFFECTING 1 LINE
    ———————————————————————————————————————————–
    761 | ERROR | Using ‘break’ outside of a loop or switch structure is invalid and will throw a fatal error since PHP 7.0
    ———————————————————————————————————————————–

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author David Lingren

    (@dglingren)

    Thanks for your report and for including the messages produced by the PHP Compatibility Checker plugin; very helpful. I investigated all three messages. The safe_mode warnings are harmless and the break error is a false positive.

    I have uploaded a new MLA Development Version dated 20161029 that corrects all three of the issues reported. To get the Development Version, follow the instructions in this earlier topic:

    Shortcode not working in (special) widget

    It would be great if you can install the Development Version and let me know how the fix works for you. Thanks for your interest in MLA.

    Hi David when will this be released?

    Plugin Author David Lingren

    (@dglingren)

    I plan to release the next MLA version around the end of November, after I can complete my testing of WordPress 4.7 compatibility.

    Plugin Author David Lingren

    (@dglingren)

    I have released MLA version 2.40, which contains the fixes for PHP 7 compatibility.

    I am marking this topic resolved, but please update it if you have any PHP 7 problems with the new version.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Media Library Assistant : php 7 compatibility’ is closed to new replies.