Support » Plugin: Enable Media Replace » Media is not being replaced

  • Hi,
    I’m trying to replace files, using this plugin, but the files won’t be replaced. I can see that the new file is uploaded to somewhere, but no matter which option I use (with or without changing file name and links), the old file keeps showing up.
    Thanks

    The page I need help with: [log in to see the link]

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author ShortPixel

    (@shortpixel)

    Hi,
    thanks for using EMR first of all! 🙂

    From what you’re describing there is likely a caching problem. Just to make sure that’s the case, could you, at the end of the URL of the replaced file add “?anything” and see if you can see/access the new file?
    For example:
    https://cropaia.com/wp-content/uploads/2013/12/Plant-nutrition-300×200.jpg?anything

    I look forward to hearing from you,
    Alex

    Hi
    I am having the same issue.
    i followed your steps above.
    without the ?anything i see the old media
    and with the ?anything is see the new media.

    is there an fix for this?
    regards
    Gaz

    • This reply was modified 1 year, 4 months ago by gaz9012.

    I have the same issue. With ?anything I see the new file.
    But when I go back (not back in browser, but just return to the page with the file on it) it shows the old image.

    Adding ?anything to the page doesn’t do anything.

    Yes, I’m having the same issue here as well, trying to use the plugin to update a PDF but it still will display the old (“replaced”) version.

    I’m having the same issue. I also opened a different browser and it didn’t display new image. However, adding ?anything worked.

    This seems to be similar to another issue I had last week trying to edit css file on site. The css file would not update unless I changed the version number in the css file.

    From what I recall it was something to do with the headers being passed. I’m not sure if wordpress core changed or something. I used to be able to upload new image and instantly it changed just as I used to be able to update css file and it would update. In the past it would work just doing a hard reload but not anymore.

    Any suggestions on how to resolve?

    I found a work around,
    simple change the file name of the image or document and it will update straight away. not ideal as this is time consuming, but at least i can now get my images sorted out until a fix has been sorted

    Plugin Author ShortPixel

    (@shortpixel)

    Thank you for your feedback on this, it looks like it could be a caching issue on the server side.
    We’ll look into a possible solution for this and try to add it in the next plugin update.

    Thank you for your support and patience! 🙂
    Alex

    Hello, just wanted to chime in and say that we’re experiencing this issue too. Pictures seem to update, but PDFs don’t. They keep showing the old PDF.

    Hi, we have the exact same problem, can’t replace any media, it just doesn’t do anything.
    And we really need this plugin right now 🙁

    Hi, is there anything new on this topic? I have the exact same issue on my website. It helps to add ?sdadasdsad, but – of course – it doesn’t solve the problem. Caching serverside was previously turned on, but now it has been turned off and it doesn’t help at all. There is no caching in WordPress. I tested the images through different web browsers and also in incognito modes.

    I know, your plugin is great, because I used it previously on another web page, so I’m looking forward for it to work (someone turned on a plugin that compressed all the images in a non-acceptable way, without a backup, so I need to replace over a hundred of them manually…).

    We will be looking into it on our server, maybe there are some more issues serverside. But if you had any more ideas, what we can check etc., it would be great.

    I’m having the same problem.

    Try purging the website’s cache and also the cache on your local computer.

    @boblenz Thanks for the response, but I had already tried that.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Media is not being replaced’ is closed to new replies.