Support » Fixing WordPress » Media image upload problem

  • When I try to upload an image using the Upload New Media page (Media|add new) I get an IO error or a HTTP 500 error depending on which version of the uploader I use.

    I’ve seen all sorts of ‘solutions’ to this on the WP forums but nothing works for me.

    I’ve deleted all the core WP files from the root WP folder and the wp-admin folder and the wp-content folder and uploaded these again from the original WP download site but the problems still exists.

    There must be something in my 1and1 dedicated server WP environment that is causing a problem.

    Do you have any ideas?

    Do you know how I can pin point the IO error more closely? Is there any logging that will help?

    I’ve looked in /var/log/httpd and the messages log in /var/log but there is nothing relating to an IO error or HTTP 500 error.

    So far I’ve tried:
    1. Upgrading to PHP5
    2. Adding this to the htaccess file in the root of my web site:
    #BEGIN Image Upload HTTP Error Fix
    <IfModule mod_security.c>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off
    #END Image Upload HTTP Error Fix

    3. Adding this to the htaccess file in the root of my web site:

    AddType x-mapp-php5 .php
    AddHandler x-mapp-php5 .php

    4. Setting the permissions on the upload file to 755
    5. Reinstalling wp-admin and wp-included plus all the files in teh root of my wordpress installation
    6. Disabling all the plugins
    7. Using different themes (the problem affects more than one word press installation on this Linux server)

    I’ve looked at these posts:




    It’s clearly something related to my server enviroment so does anyone else have any suggestions?

    Many thanks

Viewing 4 replies - 1 through 4 (of 4 total)
  • I apologise if this isn’t a terribly helpful ‘solution’, but I found 1&1 no end of trouble when trying to run a WordPress site on them.

    I struggled with this and other similar problems. Life got much better when I moved.

    If changing hosts is an option, I strongly advise you to take it. 1&1 are dreadful.

    I know what you mean about 1and1 – I don’t disagree.

    There must be a logical cause the for the problem I’m experiencing. All the suggestions so far have been almost random. I need to know what’s going on so that I can solve the problem…

    Has anyone else seen this issue?

    There seems to be lots of suggested solutions on Google but none have worked for me.

    Is anyone able to suggest what I could look for in the logs to diagnose this properly so that i can finally get this resolved?

    I have been struggling with this issue since migrating to a new server a month ago. I naturally assumed the issue was related to the move as all of my WP installations were experiencing it.

    The each have slightly different setups but also several common plugins.

    A colleague and my hosting provider’s tech support were all able to upload images and import sample template data via .xml files, with no problems whatsoever.

    In addition to every possible solution mentioned here already, I also tested with Firewalls and AV disabled. No joy.

    I also test with cable attached and wireless turned off. No joy.

    After pulling out my hair, I eventually tested via Chrome and uploading via the Flash uploader and ‘manual’ worked fine. Why I never thought of that one earlier remains a mystery.

    However, some hours after rejoicing, the problem returned.

    Initially, I was also having some luck using an alternative computer on the same network but now no browsers work on any device, no matter whether wired or wireless.

    I even tried with a wireless USB modem with no joy.

    I also tried a completely different hosting provider which worked. However, I may need to test over a longer period to see if the issue returns as previously.

    What does all this mean? I have absolutely no idea.

    My tech support was able to identify some oddness in the server web logs which seems to suggest that the connection is timing out while uploading data, this may be due to the connection of the network (slow upload speed), browser issue or some software filtering the http port on the computer.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Media image upload problem’ is closed to new replies.