WordPress.org

Support

Support » How-To and Troubleshooting » Media getting uploaded to an old date directory

Media getting uploaded to an old date directory

  • I’m having a weird issue on a site: when I try uploading something from the media uploader (flash and normal methods), the file gets uploaded correctly, but on a old directory (2011/01).

    Anyone else having this issue? The only thing I can relate to is a file permissions issue that caused the media uploader and automatic updates to stop working for some time, but then I even moved the site to another host and the problem persist.

    The upload path remains “wp-content/uploads”, the sort by date checkbox is checked, and even running a search on the wp-options table I don’t find “2011” stored anywhere.

Viewing 9 replies - 1 through 9 (of 9 total)
  • esmi

    @esmi

    Forum Moderator

    Are the images attached to a post or page that was created/published in 2011/01?

    Nope, I’m right in the Media -> Add New section.

    Thanks for the quick response!

    esmi

    @esmi

    Forum Moderator

    Have you checked the server’s timestamp?

    Yes, server timestamp is correct, I’m getting the current date going to Settings -> General.

    esmi

    @esmi

    Forum Moderator

    Have you tried:

    – deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the Twenty Eleven theme to rule out any theme-specific problems.

    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    – re-uploading all files & folders – except the wp-content folder – from a fresh download of WordPress.

    I’m having the same issue. All of my media is being uploaded to /uploads/2011/08/ folder. Doesn’t matter if I’m uploading from a post or Media » Add New page.

    @alesub, did you find a solution?

    Moderator Andrew Nevins

    @anevins

    Forum moderator

    Have you tried the methods recommended by Esmi?

    I never got to solve the issue, it got solved after I migrate the site to another hosting, so it’s definitively something related to the server.

    @andrew, Yes, I deactivated all my plugins, then tried uploading from Media » Add New. My image still uploaded to the earliest dated folder (/uploades/2011/08/) rather than the current month.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Media getting uploaded to an old date directory’ is closed to new replies.