Support » Fixing WordPress » Media Folder doesn’t display uploaded images, appears empty

  • Hi,
    I’ve uploaded a number of images via the system, all of which I can see in my files via ftp. When I open media library, it just appears empty and WP cannot find the files. Any ideas would be much appreciated.

Viewing 2 replies - 1 through 2 (of 2 total)
  • That’s actually an image upload issue I don’t recall seeing before. Congratulations! 🙂

    So, you upload via WP core functions (Media Uploader/Upload tabs on the post editor) and the images upload as verified by poking around via FTP, but the Media Library is empty? Correct so far?

    I’d check a few things.

    1. Try reuploading WP core files. You may have a missing or broken file
    2. Check the permissions on the the Upload directory. I guess you could have some odd write-but-not-read setting.
    3. Search the wp_posts table in the database for some of your image titles. Look in the post_title and the guid fields
    4. Search the wp_postmeta table in the data base for some of your image titles. Look in the meta_value column.
    5. Check back here later. Maybe somebody smart will have an idea.

    Did you repoint WordPress to a different folder on your server recently? I’m having a similiar issue, and it’s because of that, I believe.

    I don’t know my own solution yet, but I’m looking.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Media Folder doesn’t display uploaded images, appears empty’ is closed to new replies.