Support » Fixing WordPress » Media files not visible in library

  • Hello;

    For 8 months I was able to upload and store jpgs into my library and then place into my blog posts.

    From about 2 months ago, I can no longer see any media files in my library when going to place media. No new or old files. However I can see the media in the library if I access it directly, from the left column of options. I just cant see the media when wishing to place into the blog.

    I have read other posts of this issue which I do not understand, suggesting reinstall WP or change file names? I am running all of this through a browser…I have also tried both Chrome and IE, same results.

    many thanks in advance

    -Jon

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • hi,
    maybe you have javascript issues on the edit-page — this could prevent your media from loading correctly. If you know how to work with developer tools in your browser: check if there are any errors when you open the admin page. This might help: https://codex.wordpress.org/Using_Your_Browser_to_Diagnose_JavaScript_Errors

    sometimes a plugin could trigger the error: try turning all plugins off and check if you still have the issue. sometimes an error notice might be the guilty one, check in your wp-config.php if you have debug enabled (https://codex.wordpress.org/Debugging_in_WordPress)

    hope this helps (otherwise, could you share a screen shot?),

    Thread Starter jonnyssmith

    (@jonnyssmith)

    Thanks Veerle;

    To be perfectly honest I really dont understand the contents of the links you shared, I am just someone who has a simple personal blog, I’m not a coder at all. I’m not doing anything complicated I thought, just wanting to upload images to my library and then page

    How do I turn off plugins? I thought that since the issue occured both in IE and Chrome, its unlikely to be a plugin issue?

    I would share a screenshot but can not see any way to add an attachment to this message?

    many thanks

    -Jon

    hi, np!
    and attachments won’t work indeed, my bad. you’d have to post a link to the screenshot (don’t bother 😉

    You could try other browsers first if you want (Firefox, Opera, ..)
    Do you know something that might have changed since the last time the media library worked normally? (a new plugin, a new theme, some updates, …)

    I could be dead wrong, but I’d guess something on your site (maybe a plugin, maybe something in your theme) is triggering an error on the edit-post page. Preventing the media library to show correctly.

    To turn off the plugins, go to the admin page and choose Plugins (left side menu). Normally you’d see a list of all plugins you have installed and you can see the ones that are activated. You can then check them and deactivate all, just remember which ones were activated so you know which ones you have to turn on again 🙂

    I’d turn them all off, and then recheck the edit page. If the error is still here: the plugins aren’t the cause and you can turn them all on again. If the error is gone: it was one of the plugins. You could then turn them on one by one, keep rechecking the edit-page to see which plugin caused the error;

    Hi,
    Any update on this problem ?

    I have the same issue… but I found out that it is only not visible when selecting the “grid mode” and “all media files”.
    When selcting the “list mode”, or “only pictures” all is showing again.

    Problem is when trying to add a picture to a product category or to a product, then I can’t select the list mode and the page is blank

    Same problem here.. no items showing in media library but if I switch to List Mode I can see everything. I’ve tried everything, (disabling all plugins 1 by 1, updating all plugins, file permissions, logging in and out, manually uploading images through FTP, clearing browser cache, multiple browsers, disabling firewall security on server)… this is driving me nuts…

    Think the main difference between list view & grid view is that the grid view is fetching the images via ajax (a different request to the server to fetch the pictures). So they act differently, and therefore I think the issue might be in the ajax response.

    Something seems to go wrong when WordPress tries to fetch the images via an ajax-admin request. This can be caused by a php error in your theme, child theme, one of the plugins, …

    Try to check this:
    – open the page in chrome (new post) (or another browser with dev tools)
    – open the developer toolbar, choose the tab ‘network’
    – push the button ‘Add Media’
    – see whatever request and response is on the 1st line in the network panel

    This should be a request to /wp-admin/admin-ajax.php. Click on this request and choose ‘response’ in the adjacent panel. This should be something like ‘{“success”:true,”data”:[{“id”:252,”title”:”thetitle”,”filename”:”thename.png”,”url”:”https…”,…

    If you see anything else than a success response, this might give an indication where the error is..
    https://codex.wordpress.org/Using_Your_Browser_to_Diagnose_JavaScript_Errors

    If you see a SyntaxError, check this conversation: https://core.trac.wordpress.org/ticket/37036

    I had a similar issue, with the images not showing up in grid view. What I noticed was the file url was incorrect when the images were listed in list view, it was showing httpa://… instead of https://…, I somehow had mis-typed the url in the database when migrating the website, this issue was rectified by editing the siteurl field in wordpress database table *_options (where * denotes the database handle used for the wordpress installation).

    Hope this is helpful to someone.

    Ok, I’m having the same problem with recently uploaded images not being visible. None of the previous suggestions make any sense to me. I’ve tried the only remedy that seemed possible for me to do and it did not work. This has just happened today. I got a notice last night that WP was upgraded to version 5.2.2. I strongly suspect that this upgrade is the culprit, but I have no idea how to go about getting this problem fixed and the online help system is mostly useless, in my experience.

    Is anyone out there having a similar problem, since the recent upgrade or anyone with a suggestion about curing this problem?

    Same issue occurred in my page as well after apache encription. I redirected all http usage to https, and that problem showed up. I reverted back to No Redirection, and problem solved.

    I performed the same method on my other 2 sites but the problem only occurred on this one. So if everything else were correct (File permissions etc.), you should check your http/https configurations whether you are using cerbot or not.

    Hopefully that helps.

    > certbot –apache -d tech.gonjumix.com
    ……………………
    Please choose whether or not to redirect HTTP traffic to HTTPS, removing HTTP access.
    – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – –
    1: No redirect – Make no further changes to the webserver configuration.
    2: Redirect – Make all requests redirect to secure HTTPS access. Choose this for
    new sites, or if you’re confident your site works on HTTPS. You can undo this
    change by editing your web server’s configuration.
    – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – –
    Select the appropriate number [1-2] then [enter] (press ‘c’ to cancel): 1

    • This reply was modified 2 years, 1 month ago by gonjumix.
Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Media files not visible in library’ is closed to new replies.