Support » Multisite » [Resolved] Media files not uploading to correct dir after wp3.6

[Resolved] Media files not uploading to correct dir after wp3.6

  • Moderator Bet Hannon


    In researching my open-basedir errors (http://wordpress.org/support/topic/open_basedir-restriction-with-media-files-after-upgrade-to-36?replies=3), I just realized that since the upgrade to 3.6, the media file uploads for SOME (but not others) the sub-sites are going into wp-content/uploads/2013/08, which had previously only been the upload location for the main site.

    Uploads from individual sites HAD been going into blogs.dir/(site#)/files/2013/08.

    Those affected sites are not able to display previously uploaded images.

    Obviously, something in their image paths is messed up, but I can’t figure out how to fix this, since it only involves a few sites.


Viewing 9 replies - 1 through 9 (of 9 total)
  • Moderator Bet Hannon


    In researching further, now I’m wondering if the problem is related to the change in upload file path with the upgrade to 3.5. This multisite install started earlier than that (created in March 2011, but I don’t remember which version of wp).


    Is there a change in the .htaccess file that will fix this?

    I definitely don’t want to muck about in .htaccess without some guidance!

    Moderator Bet Hannon


    Realized that I should probably post a copy of the .htaccess file:

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule . index.php [L]
    #Change upload limits
    php_value upload_max_filesize 3M
    php_value max_execution_time 600
    #Change upload limits end 
    AddHandler php-stable .php

    It does have the suggested:

    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]

    Can’t figure out why this is only affecting about 25% of the subsites and not all of them….

    What’s the same about the 25%? Are they all created recently?

    Go tp /wp-admin/network/sites.php and edit one of the affected sites.

    What do you have for:

    Upload Path
    Upload Url Path
    Fileupload Url

    (if they’re missing it’s okay!)

    Moderator Bet Hannon


    Hi Mika! Nice to have you back! 🙂

    Upload Path: nothing

    Upload Url Path: (nothing)

    File upload url: http://mccphoenix.mainsite.com/wp-content/blogs.dir/61/files

    Moderator Bet Hannon


    The sites aren’t all created recently, but I just realized that they are all using ithemes’ Builder child themes.

    If you have anything I can add based on the upload settings, let me know. I’ll be contacting ithemes for support.

    My vacation was much needed! (Now let’s hope I don’t have an ear infection… *sigh*)

    So … okay. Two ways to test!

    1) Change a site from ithemes to default, see if it works 😉

    2) Make a test site, with a default theme. Check if it works, then change to ithemes.

    If ithemes is using timthumb, that might be doing it, or if they hard coded in image paths :/

    Moderator Bet Hannon


    1) Changed an ithemes child to default, and that does fix the problem.

    2) Created a new site, looked fine in TwentyThirteen (love the color bubbles at the top!). Changed to a Builder child theme, and (as usual when you use a child theme on a new site), had to upload the header image again. And it worked fine!

    3) Went back to an affected site, re-uploaded the header image, and it worked!

    Not sure WHY this happened, but I’ll be spending the afternoon re-uploading header images…

    Thanks, Mika!

    Huh. I wonder if there’s something hinky in iThemes that overwrote things when upgrading. I would report it to them, just in case.

    Moderator Bet Hannon


    Already done! 🙂

    Just glad that THAT problem is fixed!

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Resolved] Media files not uploading to correct dir after wp3.6’ is closed to new replies.