Support » Fixing WordPress » Media files not deleted from server

  • I’ve deleted several media files (PDFs) off my media library, but the links all still work and people are still able to access these PDFs. I don’t see the files in my media library (no trash folder either) anymore so they must still exist somewhere on the wordpress server.

    How do I go about getting them deleted off the wordpress server?

Viewing 6 replies - 1 through 6 (of 6 total)
  • Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    Are you using any sort of caching plugin, or do you see a “Clear/Purge Cache” button in your Dashboard or admin bar? If so, would you please try clearing the cache?

    Note: You do not need to install a caching plugin at this point just to clear a cache you don’t have. If you don’t have a caching plugin or a way to clear a server-level cache, just say so. 🙂

    Also, by “off the wordpress server” do you mean you have a site hosted on WordPress.com? If so, to clear up any confusion, WordPress.com and WordPress.org are two different entities: https://wordpress.org/support/article/wordpress-vs-wordpress-com/

    WordPress.com has complete documentation and support contacts at https://wordpress.com/support/

    Thread Starter hannahlim

    (@hannahlim)

    The first thing we tried was to clear our cache but that unfortunately did not work!

    I believe we have a WordPress.org site seeing that we have a “Thank you for creating with WordPress” link at the bottom of our dashboard.

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    Access your server via SFTP or FTP, or a file manager in your hosting account’s control panel (consult your hosting provider’s documentation for specifics on these), and navigate to /wp-content/uploads/

    Are the files still there?

    Thread Starter hannahlim

    (@hannahlim)

    Hi James!

    We tried that and no the file is no longer in there.

    We tried to uploading a new file with an identical name next hoping that it would override the old file but unfortunately the old file is still displayed when someone hits the url.

    When we look into the server as well, we can now see the new file, but for some reason what is displayed when someone tries to access the link, is still the old file.

    Hi James,
    I have the same issue, I removed all images in Media Library (I mean delete permanently) but I images files are still there via FTP.

    Ruanna

    (@ruanna)

    Similar situation here, on at least one site.

    Deleting a PDF from my media library does not delete it from the server. My first clue was the new replacement pdfs were being appended with numbers – 1, 2, 3, etc.

    My pdfs are attaching to a bi-directional “Relationship” field using Pods. I thought maybe deleting from both “related” custom post types, and also deleting from the media library, would remove the pdf from the server, but nope.

    • This reply was modified 5 months ago by Ruanna. Reason: more info
Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.