Support » Theme: Minamaze » Media files can't upload

  • Resolved jjvidaca

    (@jjvidaca)


    Whenever the Minamaze theme is active, I am unable to upload image files with large dimensions. I either get “An error occurred in the upload. Please try again later.” or “HTTP Error”.

    I’ve tried and I cannot upload a 382 kB 589×760 PNG, 40kB 700×329 PNG, 132 kB 899×679 JPEG, nor several others around the same pixel size.

    I can upload a 3 MB PDF, a 56 kB 640×817 JPEG, a 2kB 400×400 PNG, and a 5 kB 64×64 PNG without issue.

    This is what I have tried:
    -Disabling all the plug-ins, yet it still does not work. Yet I can do it if I have any other theme, no matter what plugins are active or not.

    -I’ve going from WordPress 4.01 to 4.1, still no luck.

    -I’ve tried completely removing the theme from WordPress, and verifying via FTP, and then re-installing it from the ZIP provided by your theme’s page on WordPress.org

    -I’ve tried installing the theme on a different WordPress 4.01 site, on a different domain, that has different hosting, yet I get the same result. All default settings and no customization. Cannot upload those files.

    Any ideas?

Viewing 12 replies - 1 through 12 (of 12 total)
  • Hi!

    This is not a ”solution” to the problem – rather a workaround.

    Can you upload the images using (s)ftp or scp directly to your server, and then access them from your media library?

    Your uploads should be in:

    /wp-content/uploads/

    Like I said, not a solution, but maybe this way you could at least access the images from within WP.

    Sonai: Still didn’t work. I’ve already tried those .htaccess changes. As well as looking at the path to the media folder. Everything points to the theme having issues. I can’t get the theme to allow uploads on either of my sites when they have big photos. Yet any other theme will work just fine.

    Any other possible solutions? Is there something special this theme does with uploads.

    These are some of the errors I’m seeing in the logs:

    ====================Log 1====================

    [fcgid:warn] (104)Connection reset by peer: [client <strong><IP></strong>:63615] mod_fcgid: error reading data from FastCGI server, referer http://www.mywebsite.com/wp-admin/upload.php
    [core:error] [client <strong><IP></strong>:63615] End of script output before headers: async-upload.php, referer http://www.mywebsite.com/wp-admin/upload.php

    ====================Log 2====================

    [core:error] [client <strong><IP></strong>:50743] End of script output before headers: media-new.php, referer http://www.mywebsite.com/wp-admin/media-new.php
    [fcgid:warn] (9)Bad file descriptor: [client <strong><IP></strong>:64298] mod_fcgid: ap_pass_brigade failed in handle_request_ipc function

    ====================Log 3====================

    [access_compat:error] [client <strong><IP></strong>:42109] AH01797: client denied by server configuration: /var/chroot/home/content/01/2345678/html/mywebsitefolder/main/wp-content/uploads/evex.php, referer http://www.mywebsite.com/wp-content/uploads/evex.php
    [access_compat:error] [client <strong><IP></strong>:42549] AH01797: client denied by server configuration: /var/chroot/home/content/01/2345678/html/mywebsitefolder/main/wp-content/uploads/_cache.php, referer http://www.mywebsite.com/wp-content/uploads/_cache.php

    Here’s some helpful troubleshooting steps here:

    http://rockdio.org/ayudatech/solution-to-3-5-an-error-occurred-in-the-upload-please-try-again-later/

    I just resolved this same issue. Found a problem in my functions.php.

    Theme Author ThinkUpThemes

    (@thinkupthemes)

    Hi jjvidaca,

    This issue is being caused due to a restriction placed on your site by your web host. The reason why it appears with Minamaze and not other themes, is because Minamaze creates copied of each image you upload. The correct image size is then automatically used when needed to reduce page load speed time. As a result Minamaze needs longer to upload and create image copies.

    To fix this issue please speak to your webhost and ask them to increase the max_execution_time variable to 300 seconds. Alternatively, you can achieve this by editing your wp-config.php file for your domain. To do this please follow the steps below.

    • Open wp-config.php in your sites main directory via FTP (or cPanel)
    • Scroll to the line which reads /* That’s all, stop editing! Happy blogging. */
    • Add the code set_time_limit(60); above the line /* That’s all, stop editing! Happy blogging. */ text

    This will override any conditions placed on your site by your host and you should now be able to upload images.

    I hope this helps!. Let me know how you get on 🙂

    Hi I’m having the same problem of not being able to upload any media files to my WP. I have godaddy hosting and called them, and we tried fixing it on both ends. It’s not the hosting, and the problem seems to be in word-press itself. It won’t upload no matter what theme I’m using, not by going through the FTP server or by the browser/flash uploader on the site. It’ll load 100% onto the site then read: HTTP Error.

    Going through the FTP loads the pictures onto the server, but even being in the WP content folder doesn’t put them on the dashboard media file library.

    Help?

    Thanks ThinkUpThemes, I got it working again for now. I just had to set it to set_time_limit(90)

    I just verified with the designer and they say it is working for them now as well. Thanks again.

    Theme Author ThinkUpThemes

    (@thinkupthemes)

    Hi jjviaca,

    Glad to hear the issue is now resolved!

    If you get a chance we’d absolutely love for you to leave a review for Minamaze. Don’t worry if you don’t get a chance, we know how busy it can get when building a new site. 🙂

    If you have anymore questions let us know!

    OMG, thank you so much! Adding set_time_limit(90); to the wp-config file seems to have worked for me, too! (I’m using the Enfold theme, btw — seems like this is a general wordpress issue, as opposed to theme-specific).

    Uncheck the box “Organize my uploads into month- and year-based folders” under SETTINGS > MEDIA > “Organize my uploads into month- and year-based folders”

    That will fix the upload issue!

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Media files can't upload’ is closed to new replies.