Support » Theme: Customizr » Media error after upgrading to 3.8

  • Resolved Heikinheimo



    I have this problem with uploading and deleting media after I updated my wordpress to 3.8. It might that the problem isnt caused by Customizr theme, but there are some errors that directly connect to Customizr.

    So, my problem is like this:

    When I try to upload new media in Add New section all I get is a red “HTTP error” below Upload New Media header. Drag and drop method or Selecting files method or browser uploader method dont work.

    When I Select files or drag them I get a HTTP error, but image shows to be uploaded 100% (and the image is actually uploaded to the right folder fully – I checked it with ftp client). But there is no thumbnails generated nor do I can edit the image nor see the image on live page.

    When I try to use the browser’s build-in file uploader I get “Internal server Error” with the following text:

    “The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, [no address given] and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.”

    Its the same thing with this one: no thumbnails created, cant edit the image, cant use it on a page or cant view it on a page.

    And when I try to delete those images with no thumbnail picture from Media Library I get the following error message:

    Warning: Illegal string offset ‘file’ in /home/…/public_html/wordpress/wp-content/themes/customizr/inc/class-fire-init.php on line 642

    Warning: Invalid argument supplied for foreach() in /home/…/public_html/wordpress/wp-content/themes/customizr/inc/class-fire-init.php on line 643

    Warning: Cannot modify header information – headers already sent by (output started at /home/…/public_html/wordpress/wp-content/themes/customizr/inc/class-fire-init.php:642) in /home/…/public_html/wordpress/wp-includes/pluggable.php on line 896

    I have tried following solutions but nothing have worked.
    1) I have disabled all plugins
    2) I have re-created plugins folder anew
    3) I have tried several other themes
    4) I have reinstalled wordpress
    5) I have deleted whole site and replaced it with fresh copy of wordpress and then uploaded my own .htaccess & wp-config.php & wp-content.
    6) I have tried to file and folder permissions in every way
    7) I have changed permalinks options in every way
    8) I have tried many different images with different names and different file sizes

Viewing 2 replies - 1 through 2 (of 2 total)
  • Hi @heikinheimo, thanks for this very detailed report.
    Can you try to disable the retina support in the customizer, under the “Images” section, and see what it does?

    Thanks for your feedback.

    Thank you @nikeo, disabling the retina support solved the last problem. Now I can delete files without errors, but I still cant upload images.

    I think that this problem I am having isnt connected to Customirz theme anymore and so I’ll mark this topic as resolved. I will try to solve this problem in some other section of wordpress support forum.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Media error after upgrading to 3.8’ is closed to new replies.