WordPress.org

Support

Support » Plugins and Hacks » Custom Post Widget » [Resolved] Media attachment page adds images to Content Block widget areas

[Resolved] Media attachment page adds images to Content Block widget areas

  • I just viewed the attachment page for one of my images in my Media Library, and I discovered that the image also appeared within the widget areas which are using the Content Block widget.

    I also discovered that if I enabled “Do not apply content filters” on those widgets, then the image ceased to appear there. However, that’s not a workable solution for me, as I need to keep the <p> and
    breaks in the Content Block widget.

    I’ve seen in your FAQ, and in other posts here on the Support forum, that badly written plugins can cause this problem. However in this case I’m viewing a media attachment page, and not a page generated by some other plugin. So the problem seems to be part of WP itself in this case??

    Is that correct? And is there anything I or you can do to fix this?

    Thanks!

    http://wordpress.org/extend/plugins/custom-post-widget/

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Johan van der Wijk

    @vanderwijk

    Did you maybe check the option Show featured image on the widget?

    No, I didn’t. And the content block didn’t have a featured image anyway.

    Can you not reproduce this yourself?

    Plugin Author Johan van der Wijk

    @vanderwijk

    No, I have not been able to reproduce it, this is an example of a media attachment page on my own site which has 3 custom post widgets in the footer. As you can see the image is not displayed there: http://vanderwijk.nl/diensten/wordpress/attachment/wordpress-logo/

    As checking the “Do not apply content filters” option does fix this for you, it seems that something is automatically adding the image to your post content. It does not necessarily have to be in a plugin, but could also be caused by some code in your functions.php file.

    Okay I’ll play around some more and try to reproduce it again, and let you know what I find… 🙂

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Resolved] Media attachment page adds images to Content Block widget areas’ is closed to new replies.
Skip to toolbar