Support » Fixing WordPress » Media Attach – Search returning no results.

  • When I try to attach media, using the attach, I get the dialog to search for posts or pages. But a search for posts or pages that I know exist results in nothing. Searches for invalid pages or post results “no posts found” so it appears to be searching. It was working before I deleted some images and then re-uploaded revisions to those images, same file name.

    Now I’m using custom post types, so I tried disabling those in my functions file.

    I disable all plug-ins, still didn’t work.

    I reinstalled, through upgrades to 3.01. Didn’t work.

    I manually checked my database with phpadmin, everything looks ok, I removed all revisions and repaired all the tables. Still will not work.

    I have no cache plug-ins installed, and have cleared my browser cache and tried several machines and browsers with no effect.

    I’m using the latest Genesis framework for a custom child theme. Which was was working at one point. All I changed was image, html and little CSS. And I’ve reversed all my changes, and it remains broken.

    I’m at a loss, any ideas. Is there a build in cache for the admin section I don’t know about? other then reinstalling it from scratch and manually uploading all my content. What do I look at next.


Viewing 8 replies - 1 through 8 (of 8 total)
  • I’m having this issue also – no one has any clues?

    Same thing here. I’ve tried everything I can think of: pasting in searchform.php from a site where it works fine, building test posts and pages that I know have certain content I’m searching for, even switching back to the Twenty Ten theme. Still zero results.

    Did anyone ever find a fix for this? I am having the same issue (searching for posts/pages while attaching an image yields blank search results), however, if I switch to a different theme attaching from the media library works normally. This is driving me crazy …

    I eventually found what the issue was, purely by accident – I had a temporary holding page (index.html) at the root level which was overriding the default wordpress home page while developing the site in the background.

    I deleted this page from the server and it worked as normal.

    Has anyone else had any luck with this? I don’t seem to have any extraneous index.html pages, as happynuclear seemed to have, so I’m stumped. I’ve tried on a number of installations. I’m going to check on a vanilla install and see if the issue persists.

    For me it appeared to be caused by copying theme related files between Linux and Windows. I basically started a process of restoring a theme file to its original version, checking the attach functionality, and then moving on to the next theme file if it was still broken. Eventually, I replaced the right file and attaching media worked normally. I now zip up my theme before copying it somewhere and only make changes either with the editor or on the linux console.

    The issue is not present on a vanilla install. However, you can very easily “break” a vanilla install in TwentyTen by adding whitespace (press the return key) outside of any <?php ?> tags within functions.php.

    I have logged a ticket with Trac:

    If you are experiencing this issue: look through functions.php (or any of its includes) and remove any whitespace outside of the <?php ?> code tags. For example, if you have pasted various <?php ?> blocks from different sources on the interwebs and have left some space in-between them to make it easier to read your functions.php file, strip them out so there’s no space between them, or better yet, combine them all inside 1 <?php ?> block, and make sure there’s no extra white space at the top or bottom of the file.

    I had this problem, as described here:

    For me, it works in IE8, but not FireFox 5.0.

    Go figger.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Media Attach – Search returning no results.’ is closed to new replies.