WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] maybe i’m doing it wrong…

[Resolved] maybe i’m doing it wrong…

Viewing 7 replies - 1 through 7 (of 7 total)
  • somebody please help with this… no replies at all is semi-annoying.

    What if you made the sidebar into an independent page a la popup comments template?

    You shouldn’t be in such a hurry, not all threads are answered within the same day they were started. (Referring to an own thread like this is a bit like bumping, isn’t it? *tsk tsk*)

    Yeah… but I’m on a bit of a time schedule with this. Honestly, I only referred to my own thread because I wasn’t even sure if it was in the right forum…

    My goal is to have the sidebar (the links to archives, catagories, pages, links, etc.) independent from the posts… as crudely diagramed here: http://s93111428.onlinehome.us/cbb/plan.png

    Well, in every decent theme all that stuff in blue on the left should be in the sidebar.php template.

    But I can’t simply copy that code and drop it in blank php file, or can I… ? Won’t the index I’m trying to create require some info to tell the php code that’s trying to pull the sidebar elements what to pull from?

    That’s the “punishment if you post in two places + a non-clickable link to your previous post 🙂
    = nobody is really reading what did you ask initially…
    So, you want the content of the sidebar (of the theme) to be displayed somewhere else?
    You can use any WP feature on any .php file that you create, if you put at the top of that file this:
    <?php
    require('./path_to-your-blog/wp-blog-header.php');
    ?>

    Hope this helps.

    It did help, it was exactly what I was looking for – thank you so much!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] maybe i’m doing it wrong…’ is closed to new replies.
Skip to toolbar