Support » Plugin: StatComm (StatPress Community) Multisite Edition » Maxmind database won't download properly

  • Hi, I’ve just installed StatComm and I’m trying to download the Maxmind database by clicking on the link “Click to start downloading” on the Advanced tab.

    After waiting for a few minutes as it downloads, I get these results, which look good:

    2013-05-23 12:38:27 PM – Preparing a first time install of the Maxmind GeoLiteCity database
    2013-05-23 12:38:27 PM – PHP Memory Limit is 128M, increasing is not needed.
    2013-05-23 12:38:27 PM – GeoliteCity size is about 10 MB.
    2013-05-23 12:38:27 PM – The download time depends on your server download speed.
    2013-05-23 12:38:27 PM – A timeout can happen if the download takes more than 2 minutes.
    2013-05-23 12:38:27 PM – Getting file from server…
    2013-05-23 12:40:27 PM – Done. Saving gzip file to disk…
    2013-05-23 12:40:27 PM – Done. Decompressing file…
    2013-05-23 12:40:27 PM – Done.
    2013-05-23 12:40:27 PM – GeoLiteCity.dat successfully saved and ready to use

    However, when I go back to the Advanced tab again, there is this text in red:

    Unable to open Maxmind database(incorrect version?)

    I’ve looked into the “def” folder inside the plugin directory using an FTP client. There I can see a file called GeoLiteCity.dat with a size of 0 KB. I’ve tried deleting that file and downloading again, but it just comes back with a size of 0 KB each time.

    I’ve also changed the permissions to 777 on the def folder, but no joy there either.

    Why is it not working?

    Incidentally, is Statcomm supposed to download the Maxmind database periodically so as to always have the latest version of it? Or do I need to manually download it on a regular basis?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author WPReady


    Hi GermanWiki,
    It seems the plugin has some restriction to save the file properly.
    I’m pretty sure this problem happened before. Let me research on the subject and I’ll come back with an answer.

    Just curious if you had any success in figuring this one out?! 🙂

    Plugin Author WPReady


    I finally got something but this would be different from your scenario.
    On one particular site, the Maxmind file downloaded, but finally ended up with 0KB each time.

    Straight to the solution, the theme had a small code rejecting any requests to the api core to improve speed. I took this example from Konstantin Kovshenin a WP guru:

    add_filter( ‘pre_http_request’, ‘__return_true’, 100 );

    The code is intended to use on local environments to avoid external calls to Internet and to improve development speed (it works quite alright) but accidentally went through production. This code disabled any attempt to update anything, like some sort of protection, included plugins updates like Statcomm.

    This caused the same effect you are describing. Even this wouldn’t be your case, did you try to change your theme (to default theme for example) and see if Maxmind file downloads?

    Nope, no joy there – I changed my theme back to the default Twenty Twelve theme, then tried to download the Maxmind database by clicking on the link “Click to start downloading” on the Advanced tab, but I got the same results as before…

    The results say “GeoLiteCity.dat successfully saved and ready to use”, but when I log into the server using FTP and go to the /def folder, the GeoLiteCity.dat file is there again (I made sure it was *not* there before I tried this just now) – but it still has a size of 0 KB. 🙁

    Plugin Author WPReady


    Well, that is discarding the theme as suspect.
    I’ll be digging around and I’ll let you know if I get anything.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Maxmind database won't download properly’ is closed to new replies.