Support » Theme: Cubic » Maximum posts on front page

  • Hey guys,

    how can I set the maximum number of posts on the front page? I don’t want my visitors to scroll at all, so on the front page should be all published posts always.

    Thank you in advance!
    Mat

Viewing 3 replies - 1 through 3 (of 3 total)
  • sacredpath

    (@sacredpath)

    Automattic Happiness Engineer

    Hi Mat, if you have a lot of posts (hundreds?), then it is not advisable to display them all on the blog posts page as it causes the page to load more slowly since there is so much to load, and this is particularly important since mobile/tablet web browsing has eclipsed desktop, and they may be on slower wi-fi or cellular data when they come to your site. In addition, the search engines are now looking at page loading times, and on slow sites they may actually discount your ranking in their indexes meaning that your site may be harder for web users to find when searching.

    If you do not have Jetpack Plugin installed, you might want to consider installing that and then activating the Infinite Scroll feature. What that will do is to load an initial set of posts. When the visitor nears the bottom of that set of posts, the Jetpack plugin will load another set below the originals and continue doing that until the visitor gets through all of your posts.

    To activate Infinite Scroll with Jetpack installed and connected, go to Jetpack > Settings and scroll down to Theme Enhancements and select “Load more posts as the reader scrolls down” and save the settings.

    Thank you for your quick and detailed answer. Makes absolutely sense with the loading time of the website. So the infinite scrolling is a clever solution. Just tried it, but it doesn’t really work. It still shows only exactly 10 posts on the front page, although there are right now totally 11 posts available. Weird..

    sacredpath

    (@sacredpath)

    Automattic Happiness Engineer

    Hmmm, I’m not sure what is going on. Go back to Jetpack > Settings and switch to the top selection, “Load more posts using the default theme behavior” and see if that makes any difference.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Maximum posts on front page’ is closed to new replies.