WordPress.org

Forums

Maximum execution time of 300 seconds exceeded (4 posts)

  1. jf80
    Member
    Posted 1 year ago #

    I'm trying to upload a file on my local installation of WordPress, but I keep getting this error:

    Fatal error: Maximum execution time of 300 seconds exceeded in E:\xampp\htdocs\wordpress\wp-includes\class-http.php on line 1453

    If I look in the class-http.php on line 1453 I see this:
    private function stream_body( $handle, $data ) {

    I'm not sure what to change here?

    I've also tried increasing the value on this line in the php.ini file:
    max_execution_time=300000

    But this isn't helping.

    Any ideas?

    Thanks.

  2. vidanov
    Member
    Posted 1 year ago #

    What is the file size?
    Is it the default install or with some themes and plugins enabled?

  3. jf80
    Member
    Posted 1 year ago #

    I'm actually trying to clone a site using WP Clone.

    Its a 37 MB zip file.

  4. vidanov
    Member
    Posted 1 year ago #

    I found the similar topic
    http://wordpress.org/support/topic/fatal-error-maximum-execution-time-of-60-seconds-exceeded-1?replies=15

    As the timeout is happening at wp-includes\class-http.php on line edit is and add at the start of it:

    set_time_limit (300000);

Topic Closed

This topic has been closed to new replies.

About this Topic