Support » Plugin: YITH WooCommerce Ajax Product Filter » Maximum execution time exceeded

  • Hi,

    I am using the YITH Product Filter plugin but ever since I installed it I keep getting errors like this one in my error log, and my website seems to go down for several seconds:

    PHP Fatal error: Maximum execution time of 360 seconds exceeded in /home/oliolibg/public_html/wp-content/plugins/yith-woocommerce-ajax-navigation/widgets/class.yith-wcan-navigation-widget.php on line 682

    The maximum execution time was previously set for 30 seconds but I still got error messages like the above. Line 682 is:

    // Exclude query arg for current term archive term
    while ( $in_array_function( $term->slug, $data[‘terms’] ) ) {
    $key = array_search( $current_term, $data );
    unset( $data[‘terms’][$key] );
    }

    Could you please help me fix these php errors somehow?

    Thanks,

    Nikolay

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author YITHEMES

    (@yithemes)

    Hi there,
    how many products have your store?
    Have tou tried the plugin with only WooCommerce and a WordPress theme enabled?
    Issue could depends also by a conflict with other plugins in use.
    Let me know.

    Hi,

    I have 2000 products but the error started ever since i installed the plugin and I had only 1000 products back then, so I’m guessing it’s not that. Could you please tell me how I can check if there is any other plugin interfering with this one?

    Best regads,

    Nikolay

    Plugin Author YITHEMES

    (@yithemes)

    Hi there,

    to check if there is some plugins interfering with YITH WooCommerce Ajax Product Filter, please, try to deactivate all plugins, leaving only WooCommerce and YITH WooCommerce Ajax Product Filter active, and see if the problem is solved. If so, try to activate them again, one by one, to see which one causes the issue.
    If the problem isn’t caused by a plugin, try to activate the default theme Twenty Sixteen and see if you have the same issue.
    Also, if you have customized some files in your theme, please try with a fresh installation without any customization.

    Please try this solution and let us know what’s the result.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Maximum execution time exceeded’ is closed to new replies.