Support » Localhost Installs » Maximum Execution Time Error

  • Hi, been struggling with this for a few days. I’m trying to get a cloned development site up and running for a WP blog we’ve used at work for a while now. To do so, I’ve installed WAMP (running fine) and gone through the WP install. However, when I get to the final page (when it links to Dashboard) it hangs and eventually gives a PHP Maximum Execution Time Error.
    The same occurs when I try to access the Plug-ins page, Tools page and a handful of others. Accessing most Dashboard links is fine and takes a few seconds, as does adding comments/logging in on the index page.

    Normally I would associate this with a process timeout, however I’ve edited php.ini multiple times. Setting max_execution_time to anything less than 600 results in the error, anything over and it permanently hangs.
    I’ve increased the input_load, the memory allocation and even tried setting mex_execution_time to infinite, all to either receive the error message or get it hanging (loading indefinitely and then just stopping without any change).

    I’ve tried editing the wp-config.php file and the files mentioned in the error message, no help.

    I’m running the latest version of WAMP, with PHP 5.4, MySQL 5.6 and Apache 2.4. I’ve tried other, non-WP sites and they seem to work, though phpMyAdmin does occasionally hang it eventually sorts itself out. I’m accessing via the recommended port and using localhost. WAMP is being run as Administrator and is allowed access through Win Firewall (McAfee is installed, though I can’t work out if it’s running a Firewall and shows no correlation with attempts to access the pages and logged events).

    My PC is running Windows 7 32-Bit, an i5 2400 CPU @ 3GHz, 4GB RAM and a decent graphics card (not that it should make any difference!). There is over 300GB of unused HDD space on the drive WAMP and WP are installed.

    I’m almost totally out of ideas at this point so any help is greatly appreciated. There is the possibility, as I’m doing this at work, that some Windows setting or browser setting is causing the issues though I can’t think what (I do have Admin control so can play with anything) and I don’t see why a local server would have any issues operating within the network I’m on.

  • The topic ‘Maximum Execution Time Error’ is closed to new replies.