Support » Localhost Installs » Maximum execution time

  • Hi,
    I;m facing an issue when i try to save the content after done changes into localhost it takes time and show the following error please can any one help me to solve this issue

    Fatal error: Maximum execution time of 120 seconds exceeded in C:\xampp\htdocs\codeplexus\wp-includes\wp-db.php on line 2056
    There has been a critical error on this website. Please check your site admin email inbox for instructions.

    • This topic was modified 2 weeks, 1 day ago by Yui. Reason: moved to "localhost installs"
Viewing 9 replies - 1 through 9 (of 9 total)
  • Moderator Yui

    (@fierevere)

    ゆい

    120 sec is very slow operation on database.

    Are you using modern hardware? Is your storage used for database a SSD?

    You can increase max_execution_time value in php.ini or set it to 0 for unlimited,
    but in case your database is not really that huge, there is something wrong with your server configuration (mysql/hardware)

    • This reply was modified 2 weeks, 1 day ago by Yui.
    Thread Starter banothuthiru

    (@banothuthiru)

    No I’m using HDD in my PC

    Moderator Yui

    (@fierevere)

    ゆい

    HDD

    Slow, Fragmented? Try running defragmentation at least.

    In any case, i have pointed where the problem is.

    You can check mysql.err (mysql errors log) to get more information regarding this problem.

    Dion

    (@diondesigns)

    No page in WordPress should ever require 120 seconds of CPU time, so something is definitely wrong. Is your site slow on all pages, or only when saving a post?

    Since your system is Windows-based, you should check the value of DB_HOST in your wp-config.php file. If it is localhost or empty, change it to this:

    define('DB_HOST', '127.0.0.1');

    This probably won’t fix your problem, but it should reduce page load times by 2-4 seconds.

    Thread Starter banothuthiru

    (@banothuthiru)

    I have been trying but not found I have seen the error log also nothing init

    InnoDB: using atomic writes.
    2021-04-05 17:44:18 0 [Note] InnoDB: Mutexes and rw_locks use Windows interlocked functions
    2021-04-05 17:44:18 0 [Note] InnoDB: Uses event mutexes
    2021-04-05 17:44:18 0 [Note] InnoDB: Compressed tables use zlib 1.2.11
    2021-04-05 17:44:18 0 [Note] InnoDB: Number of pools: 1
    2021-04-05 17:44:18 0 [Note] InnoDB: Using SSE2 crc32 instructions
    2021-04-05 17:44:18 0 [Note] InnoDB: Initializing buffer pool, total size = 16M, instances = 1, chunk size = 16M
    2021-04-05 17:44:18 0 [Note] InnoDB: Completed initialization of buffer pool
    2021-04-05 17:44:19 0 [Note] InnoDB: Starting crash recovery from checkpoint LSN=300288
    2021-04-05 17:44:22 0 [Note] InnoDB: 128 out of 128 rollback segments are active.
    2021-04-05 17:44:22 0 [Note] InnoDB: Removed temporary tablespace data file: "ibtmp1"
    2021-04-05 17:44:22 0 [Note] InnoDB: Creating shared tablespace for temporary tables
    2021-04-05 17:44:22 0 [Note] InnoDB: Setting file 'C:\xampp\mysql\data\ibtmp1' size to 12 MB. Physically writing the file full; Please wait ...
    2021-04-05 17:44:22 0 [Note] InnoDB: File 'C:\xampp\mysql\data\ibtmp1' size is now 12 MB.
    2021-04-05 17:44:22 0 [Note] InnoDB: Waiting for purge to start
    2021-04-05 17:44:22 0 [Note] InnoDB: 10.4.18 started; log sequence number 300297; transaction id 170
    2021-04-05 17:44:22 0 [Note] InnoDB: Loading buffer pool(s) from C:\xampp\mysql\data\ib_buffer_pool
    2021-04-05 17:44:22 0 [Note] Plugin 'FEEDBACK' is disabled.
    2021-04-05 17:44:22 0 [Note] Server socket created on IP: '::'.
    Thread Starter banothuthiru

    (@banothuthiru)

    No all pages in my site are fast when I try to save only give this issue & this issue i raised when I add the menu item to the menu bar save on that time it’s give this issue

    Dion

    (@diondesigns)

    How many menu items do you have? Saving a menu is extremely hard on a server; I’ve seen WordPress make more than 2500 INSERT/UPDATE queries when saving a huge menu.

    You should increase the size of the InnoDB buffer pool. 16MB is much too low, and that could be the cause of your problem. It should ideally be at least twice the combined size of all your databases. Ask the Xampp support people how that should be done.

    Thread Starter banothuthiru

    (@banothuthiru)

    currently I’m trying to save one item init but that issue is raising please could you tell what can I do to increase buffer pool

    Moderator Yui

    (@fierevere)

    ゆい

    You can check this article on setting innodb_buffer_pool_size
    (directive must be placed in my.cnf file in [mysqld] section and mysqld should be restarted after modifying its config file)

    https://mariadb.com/kb/en/innodb-buffer-pool/

    or this one, for dynamic pool
    https://mariadb.com/kb/en/setting-innodb-buffer-pool-size-dynamically/

    • This reply was modified 2 weeks, 1 day ago by Yui.
Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.