Support » Plugin: WordPress Button Plugin MaxButtons » MaxButtons – Ninja Form Modal Pop-Up

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Bas Schuiling

    (@basszje)

    I saw that you asked them the same question. As a general rule it’s almost never possible in WordPress to include a shortcode within a shortcode, since that confuses WordPress. Then another solution must be found.

    I checked and got it working in the following way:

    In the URL I put this: #ninja-forms-modal-1 , where ‘1’ is the form id.
    In the REL classes field put this: nf-modal:open
    In the Extra Classes field put this: nf-modal-link

    The last two fields can both be found under ‘advanced’. Good luck!

    aleadfreak

    (@aleadfreak)

    Excellent Bas, worked a treat.

    Alex

    Plugin Author Bas Schuiling

    (@basszje)

    Happy to hear!

    marcusfant

    (@marcusfant)

    Greetings,

    I seem to be following the same format, however when I click on the button, it shows the link http://localhost/wordpress2/#ninja-forms-modal-2.

    Am I needing to add the “http://” in the URL portion of MaxButtons?

    Plugin Author Bas Schuiling

    (@basszje)

    Hi,

    No you can just use the link to the modal, the portion after the # . Did you try this, or you’re having some trouble with that?

    marcusfant

    (@marcusfant)

    I did. It might be because I’m using boldgrid-ninja-forms which is a plugin from BoldGrid, but I’ll see if it will work with the original ninja forms plugin from the WordPress repository.

    Plugin Author Bas Schuiling

    (@basszje)

    You should check their documentation how they like their links. In MaxButtons you can add extra information in a few ways, depending how other plugins link their functionality ( like ‘rel’ and extra classes under the advanced option ).

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘MaxButtons – Ninja Form Modal Pop-Up’ is closed to new replies.