Support » Plugin: WP Media folders » max user connection error

  • Hi,

    I just installed the plugin and when changing the filepath of an image, it takes so long that finally this error appears: https://imgur.com/a/l2NiqRI

    After a while, the web loads correctly.

    I am using wokiee theme.

    If I use this plugin in an empty and new wordpress installation, it works fine, so I guess the theme o any plugin are causing the error.

    Thanks!

    • This topic was modified 1 week, 2 days ago by fabuky.
    • This topic was modified 1 week, 2 days ago by fabuky.

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author dbarrere

    (@dbarrere)

    Hi,

    I’m sorry for the late reply but I’m vacation, please expect some delays in my replies.

    Could you tell me the approximative number of attachments you have in your media library? And some informations on the hosting you have?

    Best regards

    Damuen

    Hi!

    There are about 600 jpg images. But I just tried to change the filepath of one image (just trying your plugin).

    The settings of the hosting are these ones (Hosting SSD Pro): https://raiolanetworks.es/hosting/

    I have asked my hosting service but it is not possible to change the “max user connections” settings, as it is a shared server. 25 is the number of “max user connections”.

    • This reply was modified 1 week, 1 day ago by fabuky.
    Plugin Author dbarrere

    (@dbarrere)

    Hi,

    Again sorry for the late reply.
    I think the problem is because you have a lot of data in your database and maybe a too low php timeout.
    The script tries to change all path in all line of the database. The request could need some time to execute if you have a lot of data in database.
    If the time it takes is greater than the php timeout then the database query will continue to run while the php script has ended.
    In this case WordPress will send another request to start again the process.
    It may fail again and let a new database connection opened and so on.

    Do you know the php max execution time?

    You could try to manually select the database tables and columns in the plugin settings where the script has to search for file location to look into.
    The default selection should work for default WordPress install, but depending on the installed plugins on your website you may have to select other tables.

    Best regards

    Hi,

    Max execution time is 600 (if I am not wrong, units are in seconds, so it is equivalent to 10 minutes). But the error (max user connections) happens pretty soon: first, the web takes a long time to refresh, and if you insist, you will get the “max user connection” error.

    You could try to manually select the database tables and columns in the plugin settings

    I don’t knwo which ones should be, so better I don’t touch anything there.

    Anyway, as I told you, the problem must be the theme or any other plugin, as in another empty website I have no problems. I am not using this plugin in this website (will only use virtual folders) so don’t take this issue as urgent, although maybe we can help someone else with the same problem.

    • This reply was modified 2 days, 13 hours ago by fabuky.
Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.