Support » Fixing WordPress » Max Upload File Size

  • Yeah,yeah, I know this has been discussed several times, but I’ve been Googling and searching but still can’t find the answer.

    in my wp-config.php file, I’ve added this:

    define('WP_MEMORY_LIMIT', '96M');
    ini_set('post_max_size', '10M');
    ini_set('upload_max_filesize', '10M');

    (I don’t know that the “ini_set” stuff is necessary. it was a suggestion to try in one of the search results I came up with, but it didn’t do anything.)

    I have already redone my php.ini file in the server to add this:

    upload_max_filesize=10M
    post_max_size = 10M

    Indeed, when I run the phpinfo.php file, it displays that these changed *did* take. My server has both of the above now upped from 2MB to 10MB.

    However, in the back-end of WordPress, it *still* shows the maximum file size I can upload is 2MB. And when I try to upload anything bigger, it refuses (Flash uploader just won’t even let me try, browser uploader goes through the process and then fails.)

    I’ve seen a lot of posts on this subject, but all solutions say that this is a “host” thing, not a “WordPress” thing. However, my phpinfo (the host) DOES show that my post and upload max is 10MB. But WordPress *insists* it’s 2 (even when my server is certainly saying otherwise). So I can’t help but think it’s *something* in WordPress that’s keeping it at 2.

    I have no cache plugins installed andor activated, and I have shut the computer down twice to make certain it’s not my cache interfering. But nope – still at 2.

    What gives? Am I missing something?

Viewing 1 replies (of 1 total)
  • Aha! Found this article, which seemed to help. The ticket that made it take for me was to open up my .htaccess file, and pop this in at the top:

    SetEnv PHPRC /home/usernamehere/public_html

    “usernamehere” being your site’s root username.

    THAT worked a treat! (Hope it helps someone else!)

Viewing 1 replies (of 1 total)
  • The topic ‘Max Upload File Size’ is closed to new replies.