Support » Plugin: WordPress Button Plugin MaxButtons » Max buttons not working

Viewing 15 replies - 1 through 15 (of 19 total)
  • Plugin Author Bas Schuiling

    (@basszje)

    I cannot see admin pages, so can’t see what’s the issue.

    I am in the same boat. When I try to copy or create, the JavaScript is rendering void(0)

    Update: it’s just in Firefox it’s not working. I’m able to get it working in Chrome.

    Laurie

    (@143laurieann25)

    Mine is in chrome and still isn’t working

    Plugin Author Bas Schuiling

    (@basszje)

    This is not helping. I can’t help if I don’t have any information.

    – Verify you have latest versions of everything
    – Check that your caches are cleared if you have them
    – Check there is an URL in the button editor settings

    If that doesn’t help :

    – Describe exactly what you did and what isn’t working
    – Post a link to a page ( not admin ) where I can see the issue
    – Any errors from the error log, any javascript warning you might see ( or anything else odd )

    Resources that might help :

    MaxButtons FAQ

    How to use the WordPress buttons plugin shortcodes

    I am having the same issue, but in my case it is even more strange.

    Only some buttons have this same issue, others, in the same Post are ok.

    I have made new buttos, copy, delete, clean cache, etc, etc.

    Nothing seems to work.

    The post is this one (from 3 buttons, only one appear) https://www.conselhosfinanceiros.com/bitcoin-o-que-e-como-funciona/

    Plugin Author Bas Schuiling

    (@basszje)

    Please don’t just dump your question somewhere, make a seperate topic otherwise I might not see and respond. Also please specify exactly what’s not working and which buttons.

    I can see a bunch of buttons on your site, they seems to work fine. You should check the developer console because your site is generating a lot of errors.

    Also always clear cache when changing buttons.

    HI,

    Since this topic was open, I did not want to get you more topics.

    The post has 3 buttons, only the last one is visible.

    And yes, I did clear the cache.

    Plugin Author Bas Schuiling

    (@basszje)

    ok, but next time I might overlook.

    Disable autoptimize and see if that works. There is not styling written to the page, I guess this plugin is eating it, and destroying a part of it – somehow.

    pro-tip; you can disable Autoptimize on a per-request basis by adding ?ao_noptimize=1 to the URL.

    if the problem is not there at that point, some autoptimize (re-)configuration might be needed to fix this. there’s more info in the troubleshooting tips and info on exclusions in the AO FAQ.

    hope this helps debugging,
    frank (ao dev)

    Plugin Author Bas Schuiling

    (@basszje)

    Thanks, already forgot about that 😀 That does seem to do the trick.

    Laurie

    (@143laurieann25)

    I will try the autopitmize as I haven’t tried that yet. But I have to e every thing else you suggested and it still doesnt work.
    I have 3 websites and it is not working on any of them.

    Plugin Author Bas Schuiling

    (@basszje)

    @lauri I can’t say anything about that, since you didn’t specify the page.

    Also I’d suggest to download the last version, out today.

    It worked: https://www.conselhosfinanceiros.com/bitcoin-o-que-e-como-funciona/?ao_noptimize=1

    Both the 3 buttons are now visible.

    The strange is that only interferes with some of them.

    But I need the Optimize plugin, is there a way (any code to exclude maxbuttons from the plugin to optimize it)? I had the same issue with Disqus plugin and I use a code to exclude the optimization of the Disqus.

    Plugin Author Bas Schuiling

    (@basszje)

    I don’t know, that something beyond the support I can give from here. There is a FAQ linked, or you can ask them.

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘Max buttons not working’ is closed to new replies.