Support » Plugin: WP Mautic » Mautic tracking broken after update to newest version

  • Resolved appscaptain

    (@appscaptain)


    Hi,

    Love this plugin. However after updating Mautic and WPMautic my tracking is broken 🙁

    Contacts are not tracked when they move around the site. have checked that the Mautic WordPress plugin is enabled and upgraded. It worked perfectly before the Mautic upgrade.

    URL: http://appscaptain.com/

    Any ideas what I’ve done wrong? Have tried everything the last couple of days, but maybe I’m misunderstanding something basic.

    I have followed all the troubleshooting steps for Contact tracking (different browser, private mode, check url etc. – and the pixel is loaded just fine (eg. Status 200 in the browser web tools) with all the parameters like page_title etc. all filled out correctly. Mautic for some reason doesn’t receive it properly.

    Mautic version 2.12.1
    PHP version 7.0.27

    The page I need help with: [log in to see the link]

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author shulard

    (@shulard)

    Hello,

    I checked your website and it seems that the tracking script can’t be loaded (404).

    
    http://email.appscaptain.com/mtc.js
    HTTP/1.1 404 Not Found
    Date: Fri, 26 Jan 2018 10:33:27 GMT
    Content-Type: text/html
    Content-Length: 162
    Connection: keep-alive
    Server: Nginx
    X-Powered-By: VPSSIM
    

    What’s your Mautic address ?

    Hi,

    Appreciate the answer. That is weird, because my Mautic address is http://email.appscaptain.com/.

    Checked again. It seems to find the script. But it is still not tracking things. Can you please look again to see?

    Plugin Author shulard

    (@shulard)

    Yep it seems that mtc.js is accessible now… Maybe there was a weird issue when I checked before.

    The Ajax requests are successfully executed and the script is loaded… I’ve made a visit from that IP address: 62.34.159.128

    Have’nt you any visits ?

    What parameters have you in the CORS settings in Mautic admin ?

    You can check using the guide : https://mautic.com/help/getting-started-mautic-cloud/#5

    Hi again Shulard,

    Sorry, I don’t see any new contacts at all. I only seem to get visits whenever someone fill out the contact form, but in that case ONLY the contact form submission is recorded. Like this:

    https://cl.ly/0V3W2X2j441P

    And then any other activity is not recorded. Eg. page visits etc. are not tracked.

    These are my CORS settings – Restrict Domains: Off
    https://cl.ly/0c2g0B3h1N0G

    Have checked the guide also.

    Plugin Author shulard

    (@shulard)

    Hello,

    Can you try to activate CORS settings ?

    I can’t find something which doesn’t work from the WP extension point of view. Maybe you can ask help on the Mautic github page: https://github.com/mautic/mautic/issues

    Plugin Author shulard

    (@shulard)

    Hello @appscaptain,

    Have you found a solution about your tracking problem ?

    Hi @shulard. No sorry, it doesn’t work even after trying different CORS settings.

    I did some more investigations and I think something changed in Mautic, as I found out it worked if you used the native Mautic forms. But not for anyone using Contact Form 7, Fast Secure Forms, Ninja Forms, Formidable Forms or Gravity Forms integrations. See this:
    https://github.com/mautic/mautic/issues/5688

    Do you have an idea of what changed in Mautic in regards to tracking between the versions mentioned in the issue?

    Plugin Author shulard

    (@shulard)

    Ok, I’ve checked your Github issue and didn’t though that you are using the “WP Mautic Form Integrator” plugin.

    I don’t know any important change in Mautic which can cause such issue… If you have access to your Mautic application logs maybe you can find informations. They must be stored in the app/logs folder.

    If you found important details here, you can add them in the Github issue. I subscribed on notifications so I’ll do my best to help here.

    I’ll close these thread because it works purely from this plugin point of view.

    @shulard Yeah, when I first posted the issue I thought it was a general problem, but then I learned later it related to that plug-in..

    Have checked the mautic and webserver logs. Nothing there at all unfortunately.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Mautic tracking broken after update to newest version’ is closed to new replies.