Support » Plugin: WP Mautic » Mautic is not tracking individual IP addresses for visitors

  • Resolved exactfunnel

    (@exactfunnel)


    Mautic is not tracking individual IP addresses for visitors. It shows only 1 IP for all visitors.

    162.241.252.242 – this is IP I see no matter where the visitor came from. I have even changed cloudflare settings to BYPASS the CACHE fOR Mautic TRacking URL.

    What else can i do? Any tips? I would love to track IPs of individual web visitors.I’ve tried a lot of things but still unable to track IPs of visitors.

    The surprising part is when I use Wordfence setting :Use the Cloudflare “CF-Connecting-IP” HTTP header to get a visitor IP…. it gives me the real IP…how do I do this setting for mautic

    Thanks

    • This topic was modified 8 months, 3 weeks ago by exactfunnel.

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author shulard

    (@shulard)

    Hello !

    Mautic is running in the client browser but the visitor IP is retrieve when the tracker script send data to the server. If you have some proxy between the users and the Mautic server this can cause that issue.

    I don’t know how you can tell Mautic to use the CloudFlare spécifique header. Can you tell CloudFlare to fill the Remote Adresse header ?

    I’m not a Clourd Flare specialist, maybe you can ask the same question on Mautic support Forum or Slack (https://www.mautic.org/support/) ? For sure you’ll find another person that already found a solution.

    Since it’s not really a WPMautic issue, I’ll close that thread. You can keep replying here if you have additional details, I’ll try my best to answer.

    I tried posting on Mautic support but no response. I have reached out to cloudflare but haven’t heard back.

    This is the script installed by WPMautic. Do you think anything wrong with it?

    <script data-cfasync=”false” src=”/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js”></script><script type=”text/javascript”>
    (function(w,d,t,u,n,a,m){w[‘MauticTrackingObject’]=n;
    w[n]=w[n]||function(){(w[n].q=w[n].q||[]).push(arguments)},a=d.createElement(t),
    m=d.getElementsByTagName(t)[0];a.async=1;a.src=u;m.parentNode.insertBefore(a,m)
    })(window,document,’script’,’https://exactfunnel.com/marketing/mtc.js&#8217;,’mt’);

    mt(‘send’, ‘pageview’);
    </script>

    i just deleted cloudflare but the error still persists. Is it surely not a plugin issue?

    Plugin Author shulard

    (@shulard)

    For sure, this plugin does not change the data which are sent using the tracker event, especially the visitor IP address… This information is extracted from the HTTP Request on the Mautic side and the plugin doesn’t have any effect here.

    The WPMautic is only here to inject the script and allow to track Mautic content from your wordpress website.

    You are such an expert. Can you please help me modifying my tracker event. Where can I modify the tracker event.

    From my guess, X-Forwarded-For HTTP header is causing the issue. How do I change the tracker event to get the correct IP?

    Plugin Author shulard

    (@shulard)

    Hello,

    Currently, the tracker event does not contains the user IP address in it’s content. The IP address is not extracted / sent from the WordPress side so we can’t change the tracking script or the plugin code to send a specific IP address.

    I asked some help on the support slack, I’ll update this thread with updates when I’ve some.

    Plugin Author shulard

    (@shulard)

    Hello,

    After discussing with a bunch of developers about CloudFlare, you must disable CloudFlare to catch all the URLs in https://exactfunnel.com/marketing.

    Mautic URLs must never be cached by a proxy to ensure every details is accessible in the tracking events.

    I don’t know how you can apply such a configuration in CloudFlare settings, but it must be a solution for your problem.

    I have uninstalled Cloudflare. But, I’m still getting the same error. I have installed WP Super Cache. Is there a way to configure it in the WP SuperCache Plugin?

    Any update?

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Mautic is not tracking individual IP addresses for visitors’ is closed to new replies.