WordPress.org

Support

Support » Plugins and Hacks » Captcha by BestWebSoft » [Resolved] math captcha not working after latest update.

[Resolved] math captcha not working after latest update.

Viewing 15 replies - 1 through 15 (of 25 total)
  • There’s been an update to Formidable’s math captcha now that resolves the issue.

    Plugin Author bestwebsoft

    @bestwebsoft

    Hi,

    Unfortunately, Formidable is not our plugin, it was developed by someone else.
    Please contact their support service.
    Please note that we can also help you if you really need this, but this service should be paid since we need some time to investigate the plugin and make the necessary changes.

    Sincerely,
    Support Team

    Same issue on 2 of my sites. 3rd one worked. The 2 that it didn’t work on has the following plugins. I’m getting the following error in my server log,

    [03-Oct-2013 18:29:15 UTC] PHP Warning: md5() expects parameter 1 to be string, array given in /home/donabona/public_html/wp-content/plugins/captcha/captcha.php on line 726

    Akismet
    All In One SEO Pack
    Better WP Security
    Captcha
    Collapsing Categories
    Contact Form 7
    Contact Form 7 Honeypot
    Debug Bar
    Debug Bar Console
    Debug Bar Extender
    Duplicator
    Gold Cart for WP e-Commerce
    Gold Cart for WP e-Commerce
    Google Analytics for WordPress
    Jetpack by WordPress.com
    Magic Zoom
    NFB Video Plugin
    Regenerate Thumbnails
    Search Tags
    Share-Widget
    Sharedaddy
    Simple Facebook Like Widget
    Simple Tags
    Simple Video Embedder
    Smart Manager for e-Commerce
    Storefront Insights
    TinyMCE Advanced
    UpdraftPlus – Backup/Restore
    Video Embed Widget
    Visual Form Builder Pro
    Wordfence Security
    WordPress Backup to Dropbox
    WordPress Database Backup
    Wordpress Facebook Like Plugin
    WP-PageNavi
    wp-Typography
    WP e-Commerce
    WP E-commerce Expanding Categories
    WP e-Commerce Predictive Search PRO
    wpsc-simple-shipping
    WPSC jPlayer Plugin
    WPtouch

    Plugin Author bestwebsoft

    @bestwebsoft

    Hi rjesse,

    Please try to deactivate all the plugins you use and then activate them one by one in order to find out the plugin that may cause the conflict. From our part we will try to trace the problem and fix it as soon as possible.

    Sincerely,
    Support Team

    captcha does not work with Jetpack

    Plugin Author bestwebsoft

    @bestwebsoft

    Hi preppermomshq,

    Could you please specify the details: what exactly goes wrong and under what circumstances?

    Sincerely,
    Support Team

    marcbkk

    @marcbkk

    Captcha not working on my site. So I have disabled it now. I was using it on the comment form and when you type in the answer (for example five − 4 =) you get an error message saying incorrect answer. A captcha isn’t much use if it can’t even do simple math correctly.

    Plugin Author bestwebsoft

    @bestwebsoft

    Hi marcbkk,

    Please provide a link to the page where the problem occurs and a screenshot of the plugin’s settings page so that we could analyze why this error occurs on your site.

    Sincerely,
    Support Team

    ehong33234

    @ehong33234

    yes, I get this error (below) on comments form. Also, I noticed that settings are not updating properly on front end after I save it on the back end. For instance, I remove multiplication option, save, but front end doesn’t update this and still shows multiplication math.

    “Error: You have entered an incorrect CAPTCHA value. Click the BACK button on your browser, and try again.”

    site: http://goo.gl/gB8EO

    I should note that I tried this on Chrome and Safari browser, deleted history and cleared cache. Still problem exists.

    *Discussed here without a solution: https://bestwebsoft.zendesk.com/entries/24000243-bug-captcha-plugin-please-read

    marcbkk

    @marcbkk

    Just switch to the SIcaptcha plugin. This one doesn’t work. SICaptcha is much better and it fixed all my problems. I removed this plugin as I don’t have time for plugins that don’t work.

    If you really want a captcha though that does math then download the Math Captcha plugin. It does the same thing as this one and works without any problems. But I prefer SIcaptcha.

    Best wishes.

    Plugin Author bestwebsoft

    @bestwebsoft

    Hi ehong33234,

    In order to help you we need a link to the page with captcha and a screeshot of captcha’s settings in your admin panel.

    Sincerely,
    BestWebSoft Support Team

    Plugin Author bestwebsoft

    @bestwebsoft

    Hi ehong33234,

    You haven’t provided the necessary information so we consider your problem resolved.

    Sincerely,
    BestWebSoft Support Team

    msteel

    @msteelnapcocom

    I am also having problems with the plugin since some resent updates. I had no problems with it for a long time and then during a recent push for registrations we were inundated with emails from frustrated users who had the correct answer but validation would fail.

    It’s been rather hard to debug as the problem is intermittent but I believe I am close to an answer.

    I think setting the raw_output parameter to true when creating the $Salt in functions encode and decode are resulting in errors for some browsers. This seems especially true when the captcha answer is one of a larger value, say 9 rather than 2.

    In short I am able to replicate the issue with larger answers and the md5 raw output set to true. Setting it to false seems to make the issue go away.

    There’s definitely an issue with the plugin, I’ve been working on this for a couple of weeks and this is the closest I’ve come to certainty as to what is happening.

    Hope this helps someone… bestweb I’d be happy to run some debugging with you.

    Thanks, I like this plugin and hope to keep using it.

    Personally I would not waste any more time with this unstable plugin. Just switch to the SIcaptcha plugin. It is excellent, visually appealing, and I have been using it for over 2 months without any problems. If you switch to SIcaptcha you can forget about the problems with this plugin and go onto something else. Just my 2 cents.

    msteel

    @msteelnapcocom

    marcbkk – the problem with SI Captcha is that it is not easy to use on a custom form, which this plugin is.

    There’s most definitely, though, a problem with the salt. When I simplify the salt this plugin works 100% of the time.

Viewing 15 replies - 1 through 15 (of 25 total)
  • The topic ‘[Resolved] math captcha not working after latest update.’ is closed to new replies.
Skip to toolbar