Support » Plugin: Master Slider - Responsive Touch Slider » Master Slider doesn't show up at all

  • Resolved Santims

    (@santims)


    Hi, i’m using the shortcode provided by the MasterSlider plugin, and it doesn’t show up in the page. The url is donnamiastyle.com/case-study-detail i don’t understand why it doesn’t working. I tried using the Widget option, and then it worked, by i need to use the shortcode, help please.

    Thank you!

    https://wordpress.org/plugins/master-slider/

Viewing 15 replies - 1 through 15 (of 19 total)
  • Thread Starter Santims

    (@santims)

    The visibility of .master-slider is hidden, if i change this it show 2 images (i think there are the two thumbnails i’m using) but it’s isn’t working.

    Hi

    Please navigate to Master Slider > Setting page and click on advanced tab and enable “Load assets on all pages” option.

    Regards

    Thread Starter Santims

    (@santims)

    Hi! Thank you so much for your answer! I checked that option and the masterslider doesn’t show up yet…

    the page is http://donnamiastyle.com/case-study-detail

    vrgeek

    (@pansphallus)

    I am having this exact same issue. I have enables load assets on all pages and i have disabled all other plugins but nothing whatsoever is showing up on my page. Is there anything else that could be causing this to happen?

    Maybe conflict with another plugin or wrong settings? Slider Settings tab –> Navigation. Is Slidershow set to On?

    Same here… I can create the slides, preview the slideshow, but when it comes to adding the shortcode to the page, it’s not recognising it and displaying absolutely nothing… I really want to use this plugin but doesn’t want to work with WordPress 4.0…

    I’m having the same issue. I can’t get the slider to show up using the shortcode or the php snippet in the theme. I really want to use this plugin but it won’t show up?!

    Same problem here. I have this error in the web console on latest Chrome:
    Uncaught ReferenceError: slider is not defined – masterslider.js:13

    ok guys having trouble with the same issue for several days ago, i have come with a solution for it.

    find the master slider js files on this location below:
    wp-content\plugins\master-slider\public\assets\js

    Add a js folder to your theme and Copy all the js files to your theme e.g. wp-content\themes\yourtheme\js

    And now,all we need to do is include those js files in functions.php

    function example_theme_js() {
    wp_enqueue_script(‘jquery’);
    //master slider js
    wp_enqueue_script(‘jquery-1.10.2′, get_template_directory_uri() .’/js/jquery-1.10.2.min.js’,”,”, false);
    wp_enqueue_script(‘select’, get_template_directory_uri() .’/js/select.js’, true);
    wp_enqueue_script(‘jquery.easing.min’, get_template_directory_uri() .’/js/jquery.easing.min.js’,”,”, false);
    wp_enqueue_script(‘masterslider.flickr.min’, get_template_directory_uri() .’/js/masterslider.flickr.min.js’,”,”, false);
    wp_enqueue_script(‘masterslider’, get_template_directory_uri() .’/js/masterslider.js’,”,”, false);
    wp_enqueue_script(‘masterlider.map’, get_template_directory_uri() .’/js/masterlider.map’,”,”, false);
    wp_enqueue_script(‘masterslider.min’, get_template_directory_uri() .’/js/masterslider.min.js’,”,”, false);
    wp_enqueue_script(‘jquery.ui.totop’, get_template_directory_uri() .’/js/jquery.ui.totop.js’, false);
    wp_enqueue_script(‘public’, get_template_directory_uri() .’/js/public.js’, false);

    }
    and dont forget to call <?php masterslider($id) ?> on your page. lol..

    hope it works..it should work by the way..haha..

    CODE IS POETRY..happy coding…

    Plugin Author averta

    (@averta)

    Hi all,
    for those who still have problem please try to update to the latest version and make sure there is no plugin conflict by switching back to default WordPress theme and disabling all the other plugins but Master Slider.

    Let us know
    Averta

    thank you very much, Amit Arya. that work for me. 🙂

    Hello Amit
    I used your function, but the only problem with “not showing up” is:
    I don’t have these lines of code in my source:

    <script src=’http://localhost/wp-content/plugins/master-slider/public/assets/js/jquery.easing.min.js?ver=2.4.2′></script&gt;

    <script src=’http://localhost/wp-content/plugins/master-slider/public/assets/js/masterslider.min.js?ver=2.4.2′></script&gt;

    When switching to my default theme, it works: the 2 lines aboves shows up and also the Masterslider!

    Any Help?

    UPDATE:

    The plugin works(!) when I add these lines manually into the <head> :

    <!– Latest version of jQuery from Google CDN –>
    <!– You can remove it if jQuery is already included. –>
    <script src=”http://ajax.googleapis.com/ajax/libs/jquery/1/jquery.min.js”></script&gt;
    <!– MasterSlider main JS file –>
    <script src=”http://localhost/wp-content/themes/Theme/js/masterslider.min.js”></script&gt;

    but it won’t work with your solution, Amit. When does the function “example_theme_js() ” starts working?

    any advice?

    This also occurs when a theme is running apply_filters(‘the_content’) on the output generated by this shortcode. Since the javascript is considered part of it, your theme can be injecting invalid <p> tags into the javascript body, causing the malfunction.

    I had to remove the filter from my theme in order to support this plugin. It would be better that I need not do that, but sacrificing good wordpress code for a good slider is an easy decision in my case.

    Honestly, I don’t see why the script can’t be added to the header. Yes it’s dynamically generated, but you can easily add custom javascript to the header in wordpress. Or at the least, keep the javascript for the shortcode (not the html), outside of THE_CONTENT. Just saying, that’s what I would do if I was maintaining this plugin.

    Peninah

    (@highlight_creative)

    I had this issue, too. A site I popped in on (didn’t code, don’t know much about what’s going on) has this plugin, and most of the themes and plugins needed updating.

    Once updated, Master Slider stopped working. In this case, I disabled the minify plugin that was installed (Better WordPress Minify), and it worked.

    I don’t know if this was an issue with the particular minify plugin or minification in general, but thought I’d post my solution.

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘Master Slider doesn't show up at all’ is closed to new replies.