Support » Fixing WordPress » Massive problems with WP 5.0.2 & Gutenberg

  • Two days ago I updated automatically all my sites to the latest WP release 5.0.2 and got after that a lot of painful phone calls.
    Nobody was able to create or edit any article.

    After some investigation I installed the classic-editor plugin on all sites.
    This solved all problems for now.

    The Gutenberg editor is not working at all. I tested that also on a fresh installation without any active plugin, without additional themes, etc.
    Nada. Nothing can be stored. It fails with an useless error message that the article cannot be stored. It leaves an empty one without any content.
    What I also saw were overlays of blocks over existing text. For what exactly should this be good? I cannot see any advantage of that. For me the complete thing is useless and more a pain.

    What is going on with the quality checks of the current WP releases? Is there no QA at the moment? Is a quality check too expensive or what is the reason?
    I don`t understand why a working editor has to be hard replaced with a buggy one and without an Opt-In option. Why I have to install the classic-editor manually instead of switching between both? Why I was not asked if I want to test the Gutenberg before?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Perhaps your server is configured differently. Here is the master list :
    https://wordpress.org/support/topic/read-this-first-wordpress-5-0-master-list/

    What is going on with the quality checks of the current WP releases? Is there no QA at the moment? Is a quality check too expensive or what is the reason?

    There was a lot of discussion as to whether to go ahead with the release or not. The release lead, Matt Mullenweg, chose to go ahead. All testing is volunteer.

    Why I was not asked if I want to test the Gutenberg before?

    There was a callout to try the new editor included in version 4.9.7 (or was it 4.9.8?) It was a Featured plugin for at least a year. It was being tested on WordPress.com and was also installed on WordPress.org, so there were a lot of people using it.

    You can be involved with the open source community, and get all the details, or you can be surprised when you install the latest version of this free software. But you can’t expect the developers to wait for your permission to change things just the way you want.

    As said this behavior is also on a clean and fresh installation without anything active.
    I tested that on different servers with apache 2.4.25 and 2.4.29, with PHP 7.2.13, 7.0.30 and 5.6.39, MariaDB 10.2.19, 10.1.26 and 10.0.34.

    All with same result: articles cannot be stored.
    The only thing what is different to the standard installations:

    I disabled the REST API globally within my WP rollout scripts which seems to be the root cause of the Gutenberg problem:

    ./wp-includes/js/dist/vendor/wp-polyfill.min.js:2:29718:
    {
    “code”: “rest_API_cannot_access”,
    “message”: {
    “status”: 403
    },
    “data”: null
    }

    As I changed that and allowed the REST API for authorized users Gutenberg is then working, but it is still slower than the classic-editor.

    What is the advantage of using the REST API for editing an article?
    There is no need to edit anything from outside.
    For me the complete REST API thing is a security risk.

    Ah yes, it uses the REST API.
    Personally, I don’t see any advantage of using it. The previous editor used AJAX for the autosaves. But the new one has blocks with dynamic content, so it incorporates more stuff. (I think they just wanted to get some use out of the big API they built.) But yes, this is the new direction, so it’s there to stay.

    I also do not trust the API, so I use the Disable REST API plugin, which allows it for authorized users only, nothing external.

    Thank you so much about this article. I’m having the exact same problem with new article and pages as well. I don’t see any advantage of using it but I’m glad this classic editor plugin is helping us.
    It worked for me as well.
    Tysm.

    My problem with Gutenberg is that my old pages a posts are not displaying as originally formatted. The main problem seems to be about missing carriage returns making the original text fall into a single paragraph. For example: https://www.wake.co.uk/2018-11-30-latin-paradise-in-bromley-civic-centre/ was originally formatted as below:

    Salsateca London and Ola Latina host an excellent salsa & bachata party night on the Last Friday of every month in the Great Hall in Bromley Civic Centre.

    Venue: Great Hall, Bromley Civic Centre, Stockwell Close Bromley BR1 3UH
    Parking: Multi-level parking available next to the venue £1.20 after 7pm but sometime free after midnight!

    Timetable:
    7:45 Doors Open
    8pm Bachata Dance Classes
    8:45 Salsa Dance Classes
    9:30 Social dancing 1am Close

    Features:
    ☆ Two Big Dance Arenas: a salsa room & a bachata room
    ☆ Top Latin DJs from London
    ☆ Salsa & bachata dance classes with the Salsateca Team + guests ☆ National & international guest artists & dance instructors
    ☆ 500 capacity venue ☆ Full air conditioning, good sound system & lighting, wooden floors throughout
    ☆ Fully licensed bar with affordable prices

    Is there anything available to display these pages as originally formatted or do I have to go through them all one by one with the classic editor to make them display correctly. For example here’s a similar page now updated to ensure that it always displays correctly: https://www.wake.co.uk/2019-01-25-latin-paradise-in-bromley-civic-centre/

    I hope you can help because I have at least 600 posts to consider! I have already edited my pages as there weren’t too many of those!

    Philip Wake
    philip@wake.co.uk
    http://www.wake.co.uk

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.