Support » Plugin: YITH WooCommerce Gift Cards » Massive Error with Woocommerce 4.0

  • davidospinacolombia

    (@davidospinacolombia)


    Hey there!
    I just updated WooCommerce to 4.0 some minutes ago, and the site throwed a Fatal Error, trying to find class-emogrifier.php in Line 105 in /yith-woocommerce-gift-cards/lib/class-yith-woocommerce-gift-cards.php
    I managed myself to solve it temporarily by modifying that function, replacing it to:

    if ( ! class_exists ( 'Emogrifier' ) ) 
    {
      require_once ( WC ()->plugin_path () . '/vendor/pelago/emogrifier/src/Emogrifier.php' );
    }

    Please check it out, and please make an upgrade ASAP! And please, tell me if I did it right, or what should be done…

    Greetings from Colombia!

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Massive Error with Woocommerce 4.0’ is closed to new replies.