WordPress.org

Support

Support » How-To and Troubleshooting » Mass Edit Comments – Delete isn’t working

Mass Edit Comments – Delete isn’t working

  • I’ve gone into Mass Edit Mode for comments, and I’m trying to delete a bunch of spam, and the Delete Checked Comments button isn’t working for me. I hit it, I get the “Are you sure?” box, and click OK, then it goes back to the same page with all of the comments still there. I’ve tried reloading to make sure it wasn’t a refresh or caching issue, but they’re really still there. Any suggestions (other than to delete them one-by-one, which will take an hour).
    This is, by the way, all SPAM that was imported from MT using the invaluable import-mt script. 😉
    Thanks!

Viewing 8 replies - 1 through 8 (of 8 total)
  • Delete is still not working with latest build of today(30/8/04).
    Now it’s showing an error,
    Warning: Invalid argument supplied for foreach() in wp-admin/edit-comments.php on line 41
    Isaack

    Same problem here, fresh install of WordPress 1.2, PHP 4.3.8, Apache 2.0.50, MySQL 3.23.58. I check any number of boxes, hit delete all comments, confirm the Javascript popup, the POST is presumably sent, and nothing has changed.
    darkness

    Quick looking around in CVS wp-admin/edit-comments.php and I found them using $_POST['delete_comments'] instead of $delete_comments. There are only two instances of $delete_comments in the 1.2 release version (one instance in CVS). Changing them all to $_POST['delete_comments'] made “Delete Checked Comments” work for me.
    darkness

    Wow! That worked for me! Very cool. Just search for “$delete_comments” and replace with “$_POST[‘delete_comments’]”

    Worked for me too — thanks for the tip.
    Brad.

    Yup, that worked for me too: any chance this could be distributed as 1.2.1p1?

    thanks this worked for me too!
    damn those spammers!

    Thanks, I couldn’t get that thing to work for the life of me. Now it works perfectly!

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Mass Edit Comments – Delete isn’t working’ is closed to new replies.
Skip to toolbar