Support » Plugin: Page Builder Gutenberg Blocks – CoBlocks » Masonry gallery error

  • Resolved rdebruyn

    (@rdebruyn)


    I went to add images to the masonry gallery on the linked page today and had the message “This block contains unexpected or invalid content” with buttons of resolve or convert to html. There were no previous issues editing this and the last change was done in Nov.

    I fixed the issue by reverting back to the last revision. I then added 1 image successfully, but then got the error message again. I wanted to add more images, so I reverted back again and added all images. Again, this was successful, but the error came back.

    There seems to be a bug. Reverting back to add images each time will be an issue. Any help would be appreciated.

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Anthony Ledesma

    (@paranoia1906)

    Hi @rdebruyn,

    Thank you for making a support request about this. I have not been able to replicate the issue you describe. You mentioned having last edited the page in November so I tried using newer and older versions of CoBlocks to test compatibility but still no luck replicating the issue.

    Please answer a few questions that might help me understand. What version of CoBlocks are you running? What version of WordPress are you running? Are you running the Gutenberg Plugin? What version? Are you running other plugins?

    Thank you in advance for the answers to these questions

    Best regards,

    Anthony

    CoBlocks Version 1.18.0

    WordPress 5.3 running Ascension theme.

    Are you running the Gutenberg Plugin?
    No

    Are you running other plugins?
    AddToAny Share Buttons
    Akismet Anti-Spam
    All-in-One WP Migration
    Contact Widgets
    Duplicate Page
    Gravity Forms
    Media Library Assistant
    Simple Lightbox
    Sucuri Security – Auditing, Malware Scanner and Hardening
    Wordfence Security
    WP101 Video Tutorials
    Yoast SEO

    I tried doing the resolve path in a local copy and it converted the block to an html block. I can try disabling plugins if you think they might be an issue. Worst case, I guess I could remove the block and recreate it to see if the issue comes back.

    – disabled all plugins except CoBlocks
    – went back to a revision from 2 months ago
    – double checked the error does not show. Sometimes I have to exit after doing the revision and then go back to the page to see it.
    – added an image and updated

    All looked ok, but when I exited and navigated back to the page, I saw the error again.

    when the error shows and the 2 buttons are displayed, there was also a … menu

    I clicked that and saw something like try to repair the block. I tried in my local copy and it worked, so I tried in my production environment and it worked also.

    I have no idea what caused the issue, but I seem to be back in business. Thanks for the quick response 🙂

    Ray

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.