Masked forwarding and on-site links (6 posts)

  1. Serena
    Posted 11 years ago #

    All of the links to pages on my site, that is, category pages, archive pages, all just produce the index, presumably because it is a masked forward. Is there a way to get to the pages I want -- short of forcing target=_blank on all links (assuming even that would work)?

  2. Mark (podz)
    Support Maven
    Posted 11 years ago #

    I don't know what a masked forward is, but the 'index' is called because when you click a link to categories, the 'index' provides the overall page structure, and the content changes.
    You could use the target attribute, but the page would still look the same as if you didn't, and if you are concerned about xhtml validity, using target breaks that.

  3. Serena
    Posted 11 years ago #

    Well, my point is, the content is NOT changing. I would like to actually get a category listing.

  4. junesix
    Posted 11 years ago #

    I would recommend checking your Permalink options and then verifying that against the .htaccess file. It seems that regardless of whatever parameters are passed to index.php in the URI, they are ignored. Have you made edits to the .htaccess file?

  5. Serena
    Posted 11 years ago #

    I've made no changes in the Permalink options or the .htaccess file. After experimenting, I see that if I put the url of my main site with WP's subdirectory in the Options' "WordPress Address" field -- i.e. the real address -- and put the masked address in the "Blog Address" field, then I encounter the problem with categories and archives. If both are the same, no problems.
    However, when I do that, the outcome of ALL links, even those for external sites, is my (masked) address in the browser address field, seemingly forever, until the window is closed. Probably this is not a WP issue, but I wonder if there's a way to prevent that.

  6. junesix
    Posted 11 years ago #

    In the case of your site, both the WordPress address and Blog address should be http://www.gypsyresort.com/okobjector.
    The blog itself is fine. I think the problem is with your .htaccess rules and how they accomplish in the URI masking. I'm assuming what you want is for http://www.gypsyresort.com/okobjector to be masked as http://www.okobjector.org. I'm not an expert with the mod_rewrite rules so you may want to search on Google or ask someone here.

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.