Support » Plugin: Lazy Loader » Markup not being altered

  • Resolved deralict

    (@deralict)


    I have the plugin installed and configured. The rendered page markup is not being altered at all, and consequently none of the images are being lazyloaded. However I know the scripts are loaded and running because I added my own markup for a background image (added class “lazyload” and data-bg=”image url”) and it is being lazyloaded without issue. But why is the normal page markup not being added?

    Note: I’m using Oxygen Builder (https://oxygenbuilder.com/)

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Florian Brinkmann

    (@florianbrinkmann)

    Hi @deralict,

    have you added the background image via Oxygen Builder, too? And is the option enabled to parse the complete markup?

    Best,
    Florian

    Thread Starter deralict

    (@deralict)

    Yes, I added the background image via Oxygen.

    The option to process the complete markup was OFF. However, I turned it ON and it all worked. I thought that the page markup would processed by default. I also didn’t want to touch that option initially because it says “it might slow down the page generation time a bit”…and the last thing I want to do is slow down the page generation by a “bit” which sounds like it could be “a couple seconds”.

    Thread Starter deralict

    (@deralict)

    Follow-up to my last message…with the “process complete markup” setting ON, the Oxygen builder UI gets completely messed up. Is there any way to disable the script on all admin pages?

    Plugin Author Florian Brinkmann

    (@florianbrinkmann)

    The option to process the complete markup was OFF. However, I turned it ON and it all worked. I thought that the page markup would processed by default.

    Great. Yes, the page markup in the database gets processed by default before being displayed, but I guess Oxygen Builder uses ways to build the markup that are not supported by Lazy Loader.

    and the last thing I want to do is slow down the page generation by a “bit” which sounds like it could be “a couple seconds”.

    »a couple seconds« are more than a bit for me 🙂

    Follow-up to my last message…with the “process complete markup” setting ON, the Oxygen builder UI gets completely messed up. Is there any way to disable the script on all admin pages?

    Hm, the plugin should not do things on admin pages. If you could send me a copy of the Oxygen builder files via Dropbox or something like that (you can find my email address here: https://florianbrinkmann.com/en/contact/), I can take a look at it.

    Best,
    Florian

    Thread Starter deralict

    (@deralict)

    Sure, I’ll send you a copy. Look for my email.

    Plugin Author Florian Brinkmann

    (@florianbrinkmann)

    Thanks for the files! I released a beta version on GitHub (https://github.com/florianbrinkmann/lazy-loading-responsive-images/releases/tag/v7.0.1-beta.1 – the lazy-loading-responsive-images.zip). Could you give it a try and check if it fixes the issue in the Oxygen editor view?

    Thanks,
    Florian

    Thread Starter deralict

    (@deralict)

    Yes! It works great! Thanks so much!

    Plugin Author Florian Brinkmann

    (@florianbrinkmann)

    Great, thanks for testing! I will release a new version to the W.org repo with the fix today.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Markup not being altered’ is closed to new replies.