Support » Plugin: Yoast SEO » Markup error in article Schema Yoast 11

  • Resolved Martin


    Google markup testing tools reports 3 errors

    It is 3x

    “The attribute publisher.itemtype has an invalid value.”

    There are several reports on Yoast Website in the comments to the same issue. So it appears to be a general problem.

    Any clues?

    • This topic was modified 1 year, 1 month ago by Martin.

    The page I need help with: [log in to see the link]

Viewing 14 replies - 1 through 14 (of 14 total)
  • wol


    For Article schema Publisher must be an “Organization”, not “Person”. That’s why it showing errors. You can solve this by selecting Organization and adding a Logo in Yoast >> Search Appearance >> Knowledge Graph &

    This is actually not true. Publisher can be a person or an organization according to

    I suspect that the faulty implementation of the publisher logo via gravatar is the culprit. The gravatar logo does not conform to the 60px / 600px Google standard fpr a publisher logo

    Having this issue as well.

    The markup says Publisher @type is Thing. Where do I change this setting?
    UPDATE: changed Publisher Type to Person. Error went from 2 entries to 3 in the validator.

    • This reply was modified 1 year, 1 month ago by pro99. Reason: Updating


    @mawalito no you are very wrong. According to, Publisher must be an Organization and must have a Logo. Here Author and Publisher are two different thing.
    You may disable Yoast Schema and apply CreativeContent makeup for a personal blog.

    Just disable Yoast Structured Data or your theme’s structured data. This error is mainly caused by schema markup duplication. (How to disable:

    Plugin Support benvaassen


    Hi all,

    There is nothing wrong with our implementation. This error shows because Google doesn’t allow a ‘Person’ to be the ‘Publisher’ of an article, while it should be perfectly valid: We think this is a bug with their code / approach / validation tool, and we’ve raised it with them.

    Plugin Support devnihil


    We are going ahead and marking this issue as resolved due to inactivity. If you require any further assistance please create a new issue.

    In the Knowledge Graph & section, I have selected Organization, entered Organization name: Decor Interiors and uploaded a logo. Unfortunately, Google Structured Data Testing Tools still does not recognize the Publisher schema.

    Additionally, despite having a Featured Image selected for each post (though positioned using shortcode in body), the tool also does not recognize Image schema.

    A value for the publisher field is required.
    A value for the image field is required.

    Having the same problem as @billferris. In my opinion it is great that you have implemented structured data in Yoast SEO, but you really should give the admins more control about this. Especially adding custom properties and change the values.

    See the errors I have in a certain project on every page.

    How would your recommend I solve this currently and will you fix it in the future?

    Es un verdadero problema el que llegamos a tener cuando estos errores suelen salir a la luz. Me ha pasado con mis paginas últimamente. Es genial que haya implementado datos estructurados en Yoast SEO, pero realmente debería dar a los administradores más control sobre esto.

    Pagina de referencia:

    • This reply was modified 10 months, 1 week ago by abner001.

    Changing from Person to Organisation and adding a logo and name solved the problem for me.

    I am working on a project for a fitness gym: CrossFitIcke and want to give Google a for sitelinks. I found an example on how I would like to influence it. For this site you can see sitelinks on Google that are not even in the source. How do they do it?

    Thanks for advise.
    Best HK

    Changing from Person to Organisation and adding a logo and name solved the problem for me.

    Reference page:



    I keep having the same problem on my new project for flowpilot

Viewing 14 replies - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.