MarketPress - WordPress eCommerce
[resolved] MarketPress Lite Breaking Non-Related Pages Associated with the slug "services" (6 posts)

  1. Mateo
    Posted 1 year ago #

    I have MarketPress Lite installed and I noticed that I kept getting a white page of death with only the words "Service Unavailable" in the output. This occurred when I tried to visit a page that what set up with the slug "services". This also affected all the child pages under services (e.g., myurl.com/services/, and myurl.com/services/first-service/, and myurl.com/services/second-service/, etc.).

    I worked around it by renaming the slug to 'my-services' (and not what my client wants).


  2. David
    WPMU DEV Support Staff
    Posted 1 year ago #

    Hi @photogmateo,

    I hope you're doing well today! :)

    Thanks for posting here, though sorry if you've had any trouble using the plugin. It sounds like there might be a plugin or theme conflict at play.

    MarketPress doesn't use the slug /services/ and the "Service Unavailable" message sounds like it's coming from another plugin rather than MarketPress.

    Could I ask what plugin you're using for that service?

    Could you also please try deactivating other plugins and switching to Twenty Fourteen theme to see how it works with that?

    For that matter, you'll find a helpful troubleshooting chart here.

    Looking forward to your reply. :)


  3. Hi @Mateo,

    Hope you're well today! Just checking back to make sure everything's sorted for ya! This thread's marked as resolved as we haven't heard back from you in a bit.

    Just let us know if it's still an issue. We'll be happy to help out.


  4. David
    WPMU DEV Support Staff
    Posted 1 year ago #

    Hey there @Mateo,

    I just noticed another user reporting this same issue here:

    MarketPress previously used the /services/ slug for Pinterest integration but that was changed back in May this year.

    Could I ask what version of MarketPress you're using? If you're using an older version, could you update?


  5. Mateo
    Posted 1 year ago #

    Hi @David,

    I didn't have time to figure our what the actual issue was so I just installed a different plugin. I can tell you it was the most recent version (free install) at the time of my original post. Nonetheless, thank you though for the follow up, it's rare to see such great customer service.

  6. David
    WPMU DEV Support Staff
    Posted 1 year ago #

    Hi @Mateo,

    Thanks for clarifying that, I'd love to find out what was causing that /services/ conflict, I was unable to replicate it, even when changing MarketPress slugs to use /services/ and creating a page with that slug.

    If you decide to look back into this, do let us know. We'd love to help get it sorted. :)

    Also, thanks for your kind words! Just let us know if there's anything we can assist with!


Topic Closed

This topic has been closed to new replies.

About this Plugin

  • MarketPress - WordPress eCommerce
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic


No tags yet.