Support » Plugin: Geo Mashup » Markers not shown (only shown when logged in)

  • Hey,

    the markers on the map are only shown when I am logged in, otherwise the map appears as a map without markers. Any idea what the reason might be?
    I tested different maps and also searched the forum, unfortunately I didn’t find any solution so far.

    If you need more information, please let me know.

    Thanks in advance!
    Chris

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Dylan Kuhn

    (@cyberhobo)

    Maybe I’m too late, I don’t see any maps on that page.

    Hi Dylan,

    thanks for your reply. 🙂
    No, you are not. Here they are: https://www.my-travelworld.de/blog-weltkarte/

    Thanks for looking into it.
    If you want, I can also send you a screenshot with the markers when I am logged in.

    Chris

    Plugin Author Dylan Kuhn

    (@cyberhobo)

    You’re getting an error that was reported once a long time ago. A quote from there:

    I don’t know yet of specific themes or plugins that cause this, but I suspect
    there are things that try make use of Google other CDN versions of jQuery that
    break standard wp_enqueue_script( ‘jquery’ ) usage.

    Still true! Plugins or theme functions that change the standard WordPress script loading process are likely the culprit.

    my_travelworld

    (@my_travelworld)

    Hi Dylan,

    thanks for your reply.

    I found the plugin which causes the Map not to work properly: Fast Velocity Minify, a plugin to combine and minify JS and CSS files.
    As I have quite a bunch of those files I wouldn’t like to turn off this plugin. However, the plugin allows exceptions and rules of which CSS and JS files not to minimy. Can you let me know the names of the crucial JS and CSS files for the Geo Mashup plugin to work? When I have them, I can try to create rules and excptions and see if it works with both plugins running.

    Thanks a lot!
    Chris

    Plugin Author Dylan Kuhn

    (@cyberhobo)

    I don’t think that will work because the issue is not any error in minified code, but that the jquery script dependency is not included at all. That said, here are the scripts and styles that are included on my site. You may not be using all of these if marker clustering isn’t enabled.

    <link rel='stylesheet' id='geo-mashup-map-style-css'  href='https://www.cyberhobo.net/wp-content/plugins/geo-mashup/css/map-style-default.min.css?ver=5.4.2' type='text/css' media='all' />
    <script type='text/javascript' src='https://www.cyberhobo.net/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
    <script type='text/javascript' src='https://www.cyberhobo.net/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
    <script type='text/javascript' src='//maps.google.com/maps/api/js?key=AIzaSyAEsrmeMkyzKbfpu-04cSZRjBDWD4HfYFU&language=en&ver=5.4.2'></script>
    <script type='text/javascript' src='https://www.cyberhobo.net/wp-content/plugins/geo-mashup/js/markerclusterer.min.js?ver=2.0.3'></script>
    <script type='text/javascript' src='https://www.cyberhobo.net/wp-content/plugins/geo-mashup/js/mxn/mxn.min.js?ver=1.12.3'></script>
    <script type='text/javascript' src='https://www.cyberhobo.net/wp-content/plugins/geo-mashup/js/mxn/mxn.core.min.js?ver=1.12.3'></script>
    <script type='text/javascript' src='https://www.cyberhobo.net/wp-content/plugins/geo-mashup/js/mxn/mxn.googlev3.core.min.js?ver=1.12.3'></script>
    <script type='text/javascript' src='https://www.cyberhobo.net/wp-content/plugins/geo-mashup/js/mxn/mxn.googlev3.geo-mashup.min.js?ver=1.12.3'></script>
    <script type='text/javascript' src='https://www.cyberhobo.net/wp-content/plugins/geo-mashup/js/geo-mashup.min.js?ver=1.12.3'></script>
    <script type='text/javascript' src='https://www.cyberhobo.net/wp-content/plugins/geo-mashup/js/taxonomy.min.js?ver=1.12.3'></script>
    <script type='text/javascript' src='https://www.cyberhobo.net/wp-content/plugins/geo-mashup/js/geo-mashup-mxn.min.js?ver=1.12.3'></script>
    <script type='text/javascript' src='https://www.cyberhobo.net/wp-content/plugins/geo-mashup/js/modernizr.min.js?ver=2.6.2'></script>
    <script type='text/javascript' src='https://www.cyberhobo.net/wp-content/plugins/geo-mashup/js/geo-mashup-markerclusterer.min.js?ver=1.12.3'></script>
    • This reply was modified 3 months, 3 weeks ago by Dylan Kuhn.
Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.