WordPress.org

Support

Support » Plugins and Hacks » markers not showing anymore after update to WordPress 3.5

markers not showing anymore after update to WordPress 3.5

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author Ben Huson

    @husobj

    I can see custom markers on your site.
    Have you been able to fix this issue?

    Hello Ben and first of all thank you for your help.
    Not at all. I haven’t modified anything since I posted the thread. I still have the issue across at least 3 different browsers (safari, chrome, firefox) and 3 different devices (Galaxy S smartphone, Google Nexus 7 tablet and Mac OS X). What was your device and browser configuration when you could see the markers ?

    Plugin Author Ben Huson

    @husobj

    Ah, I assumed the “M” and “RER” icons were your custom icons but it seems they are not?

    It seems the map on the following page is trying to use an icon called “wpgeo_icon_Visiteguidee” which is not defined.

    http://www.monparispascher.com/bon-plan-paris/visite-guide-gratuite-de-paris-en-anglais-paris-5eme

    I think you have actually defined it as “wpgeo_icon_Visite-guidee”.

    I can’t remember offhand but I thing custom marker names should only include alphanumeric characters, not hyphens of underscores.

    That may be why you are having a problem.

    I don’t understand why the icon is defined is “wp-geo_Visite-guidee”
    Here is what I have added to my theme’s functions.php for all of my custom markers :

    $markers[] = new WPGeo_Marker(
    ‘Visite-guidee’, // Identifier
    ‘Visite-guidee’, // Icon name
    ”, // Icon description
    30, 40, 10, 34, // width, height, anchorx, anchor y
    ‘/wp-content/upload/markers/!!Visite-guidee.png’, // Icon image
    ” // Icon shadow image
    );

    Most of my “icon names” and “identifiers” don’t have any hyphens or underscore. Would it be possible that somehow “wpgeo_icon_” would be automatically added prior to the “icon names” and “identifiers” I give ?
    If so, would you know how to change that ?

    What is weird though is that for months, with the same identifiers and icon names my markers had not issue appearing. I can’t understand why suddenly this has changed…

    Plugin Author Ben Huson

    @husobj

    Yes, “wp-geo_” is added to all defined markers which works correctly.

    The issue is that Marker Identifiers (“Visite-guidee”) should not contain hyphens and it can cause problems.

    Do you have many posts that us the marker Visite-guidee that you have defined?

    Actually I have a total of 24 custom markers and visite-guidee is actually the only one with a hyphen.

    Here is the list of all my custom marker identifiers :
    Panorama, Sauna, Billeterie, Cinema, Coiffeur, Concerts, Danse, Hammam, Microphone, Panorama, Pharmacie, Photo, Piqueniqueapero, Poste ,Recup ,Remiseenforme ,Restaurants ,Roller ,Shopping , Spectacles, Sumocatch, Velo, Vin, Visite-guidee.

    The problem is that the issue applies to all of them (and I think even the standard default markers)

    Here is an example of a custom marker that doesn’t have any hyphen or underscore that still doesn’t appear on the map

    http://www.monparispascher.com/bon-plan-paris/couscous-gratuit-chope-du-chateau-rouge-vendredi-samedi-paris-18eme

    Oh actually you were right ! Thank you so much 🙂
    I have just changed the name of the marker identifier from Visite-guidee to Visiteguidee and somehow it affected all of my markers.

    I now can see my other markers such as on the page http://www.monparispascher.com/bon-plan-paris/couscous-gratuit-chope-du-chateau-rouge-vendredi-samedi-paris-18eme

    However I still have one issue : my global mash-up map (http://www.monparispascher.com/carte-des-bons-plans-paris) which is supposed to display all of my custom markers somehow only displays one of them and the map doesn’t appear. Any idea why ?

    Plugin Author Ben Huson

    @husobj

    Cool, the hyphen may have been causing a JavaScript error which may have affected lots of thing – glad that solved it.

    How are you outputting your mashup map?
    With a shortcode or in a template?
    Can you post the exact code you are using?

    I trigger the global map from my index file through a php template.

    <?php if (is_page(996)) { ?><div style="align:center;text-align:center;">
    <p>Retrouvez tous nos bons plans en un clin d'oeil sur notre carte des bons plans à Paris !</p>
    <?php wpgeo_map(array(
    'category' => '260,261,286,272,210,365,370,327,271,197,198',
    'height' => '600',
    'width' => '732'
    )); ?>
    <?php } ?>

    [Moderator Note: Please post code or markup snippets between backticks or use the code button. As it stands, your posted code may now have been permanently damaged/corrupted by the forum’s parser.]

    Plugin Author Ben Huson

    @husobj

    Are you using the default WordPress posts and categories for this or sre you using a custom post type?

    I use the standard wordpress posts and categories

    Plugin Author Ben Huson

    @husobj

    Did you resolve your mash-up map issue?
    You link above seems to be display a map with markers OK now.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘markers not showing anymore after update to WordPress 3.5’ is closed to new replies.