Support » Plugin: iPanorama 360 WordPress Virtual Tour Builder » Marker not showing on ‘flat’ type scene

  • Resolved eyefinitymedia

    (@eyefinitymedia)


    Hi there,

    I have a set up a virtual tour for a client, it has 3 scenes. On one scene I use the ‘flat’ type for using a flat image. When I add markers, it won’t appear when I see the published version of the tour. It does show up in the Edit environment.

Viewing 13 replies - 1 through 13 (of 13 total)
  • Is the scene enabled with the slider button?

    Plugin Author Avirtum

    (@avirtum)

    Can you share a link to your web page? Or some screenshots from the builder.

    Thread Starter eyefinitymedia

    (@eyefinitymedia)

    Yes, the scene appears, but not the marker.

    Misunderstood what was not appearing. Included or custom marker? If custom, did you try using one of the included?

    Thread Starter eyefinitymedia

    (@eyefinitymedia)

    I tried using the included as well as a custom marker.

    Oddly enough as I am testing, I cannot turn off or change the marker icon. Hopefully Avirtum will log on. I am on iPad right now, will try from pc later.

    Plugin Author Avirtum

    (@avirtum)

    I’m here, but without a web page with a virtual tour I can’t test. I’m not a wizard.

    Thread Starter eyefinitymedia

    (@eyefinitymedia)

    Interesting, I am thinking you mean the picture of the door going into the next hallway.
    Initially I do not see the button. I can go to the next scene with the navigation buttons, and if you back up using the buttons (arrows in the top right corner) the icon does appear, and can be used. You have some other odd things going on with the tour too, and for me, is pretty slow in responding. The first part going through the room with the desk works fine, then it flips to the flat doorway and from there it wants to spin around and is hard to control.

    Right after you image, do you have:
    Generates the scene preload image to get faster pano loading experience “Checked”?
    When I do that the icons disappear.
    I can get them to appear if I use the navigation, arrow.

    Like this

    Uncheck that box and try it.

    • This reply was modified 2 months, 1 week ago by .
    Plugin Author Avirtum

    (@avirtum)

    I see the problem. The marker is not active for some reason. I will research this and report soon.

    Plugin Author Avirtum

    (@avirtum)

    It’s because than the video is playing the virtual tour canvas element has width=0. Then some code change width to 818, but the plugin do not update markers, as the results the marker is hidden.

    <canvas class=”ipnrm-canvas” width=”0″ height=”900″></canvas>

    then

    <canvas class=”ipnrm-canvas” width=”818″ height=”900″></canvas>

    Plugin Author Avirtum

    (@avirtum)

    I am attaching an example of how to implement a video splash screen before loading the panorama. To do this you need to use the custom css and js tabs.

    Custom CSS (styles for the video container)
    ===========================================

    .myvideo {
        position: absolute;
        top: 0;
        left: 0;
        width: 100%;
        height: 100%;
        background: #000;
        z-index: 9999;
    }

    Custom JS (create the dynamic video container, add source, handle the video end event)
    ===========================================

    const instance = this,
    $ = jQuery;
    
    const $video = $("<video>").addClass("myvideo").attr({
        autoplay: 'autoplay',
        muted: 'muted',
        controls: 'controls',
        draggable: true
    });
    const $source = $("<source>").attr({
        src: 'https://eyefinitymedia.nl/wp-content/themes/eyefinitymedia/img/intro-video_2.mp4',
        type: 'video/mp4'
    });
    
    $video.on('ended', () => { $video.remove(); });
    
    instance.$container.append($video.append($source));
Viewing 13 replies - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.