Support » Plugin: Jetpack by WordPress.com » Markdown stopped working

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    Sorry about that!

    Could you try to deactivate all other plugins on your site, one at a time, and let me know if you find a conflicting plugin?

    If that doesn’t help, could you post your site URL here so I can have a look?

    If you want it to remain private, you can also contact us via this contact form:
    http://jetpack.com/contact-support/

    Thanks!

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    Could you also try to add the following to a functionaliy plugin like this one on your site?

    add_filter( 'pre_option_wpcom_publish_posts_with_markdown', '__return_true' );

    Let me know how it goes.

    Jeremy — I tested on four more sites that we manage; three of them have the same issue, but I’m unable to determine what the differing factor is. I thought perhaps it was related to SSL (which was a valid theory for that 3 out of 4), but I’ve tested further and SSL doesn’t seem to affect it.

    I should add that it was a caching issue that caused the old version not to work. Downgrading to the previous version of Jetpack and then clearing the cache solves. For the other sites, I simply can’t get Markdown to work.

    Sites where it is broken:
    gearthblog.com (temporarily fixed by downgrading Jetpack)
    greenmellenmedia.com
    mickmel.com

    It’s certainly something in Jetpack 4.7, but I can’t determine what…

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    Thanks for the extra details!

    What happens when you deactivate the Markdown module, and the reactivate it?

    If that doesn’t help, could you try to apply the snippet I posted above to a functionality plugin and let me know if it helps?

    Thanks!

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    Could you also go to Settings > Writing in your dashboard, and make sure the Markdown option is checked?

    Wow, that was it! (Settings –> Writing). I didn’t even know to check there. It seems to be a new checkbox with Jetpack 4.7; some of our sites had it checked after the update, and some didn’t. Weird.

    Thanks for the help!

    Any idea what the purpose of that box is? Why not just let the main Jetpack Markdown setting control what happens on the site?

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    Yeah, that checkbox was hidden before; it’s a bug in Jetpack 4.7. We’ll get this fixed in the next Jetpack release!

    I’m following this conversation with curiosity because I noticed the same problem. Existing posts still display fine when visited, but when editing/authoring new posts, Markdown doesn’t display properly. More upsetting is that posts have been converted from Markdown to HTML! As someone who writes in MD, this means I have to go through and edit the text.

    Looking forward to the next update — perhaps an immediate x.x.1 bug fix?

    UPDATE: the temporary remedy of turn-it-off-turn-it-back-on seems to work.

    • This reply was modified 2 years, 8 months ago by scottperezfox.
    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    Looking forward to the next update — perhaps an immediate x.x.1 bug fix?

    Yes, that’s the plan. Jetpack 4.7.1 will be available in a few hours.

    Thanks for the update @jeherve

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    Coming back to this; Jetpack 4.7.1 will be delayed a bit, as we found another issue we’d like to fix.

    Until then, going to Settings > Writing and enabling the Markdown option should help. Another alternative is to deactivate and reactivate the module.

    Thank you so Jeremy, finding this setting fixed my issues as well. Much appreciated.

    I’m having issues with this as well, I’ve tried deactivating and re-enabling the module, as well as checking the new tick box, and it still isn’t working, so I am having to convert my current posts in progress to html for now.

    All of the previous posts using markdown seem to have been converted to html which is a problem as I have been using the {.rel-nofollow} attribute following links, and this hasn’t been converted properly. So now I have to search for this and manually change them all.

    Ignore me, it seems to have sorted itself out now!

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Markdown stopped working’ is closed to new replies.