Support » Plugin: MapPress Easy Google Maps » Maps Wont Display

  • Resolved klynam


    I’m running the latest releases of WP and MapPress, and after the latest MapPress update, maps no longer display on my site:

    As you can see the map appears to LOAD. The map marker appears and you can pan around with the mouse, but the map itself doesn’t display.

    Checked in all major browsers, deactivated plug-ins, and the wp_footer() call is in its proper place. No maps. Also tried deactivating MP CSS and loading the maps last options. Still no maps.

    Maps display fine if I switch to Twenty Twelve theme, even with all plug-ins activated.

    Any ideas how to fix this…???

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author chrisvrichardson



    I think the problem is that the theme is loading a very old version of jQuery, which causes an error when the map’s being rendered. The theme is loading 1.4.2, but the current jQuery version for WP 3.5 is 1.8.3.

    If you can contact modify the theme or contact the author to load the WP version, the map should work again.

    Looks like the developer on ThemeForest has stopped supporting or updating the theme.

    I tried loading jquery-1.8.3.min.js into the specified directory, and changed the js filename call in my header.php file. No luck…

    I even rolled back to MapPress v2.39 (from last December) and went back to 1.4.2.js. Still no luck.

    EDIT – Rolling back to MP v2.38 works with BOTH 1.4.2.js and 1.8.3.js, but anything past 2.39 doesn’t work with either.

    So for now, I suppose I’m stuck with v2.38 – at least it works, but I’d prefer to be running on you latest release…

    I have the same problem after updating to v2.39.9, I’m on WP 3.4.2 (haven’t yet upgraded to latest WP but I plan to). I am using the latest version of jquery, 1.8.3

    Maps won’t show up even though they are still “attached” to the post. I also had to rollback to 2.38 to get the maps to display.

    I hope there will be a fix soon!

    Plugin Author chrisvrichardson



    Your problem sounds more like the theme isn’t calling wp_footer(), without it the plugin can’t load its javascript.

    Have you already checked the theme includes the wp_footer call?

    Actually, my theme does call wp_footer()

    As mentioned, it works fine with the previous version of the plugin, no other changes than just updating/rolling back the plugin. 2.38 works, 2.39.9 doesn’t.

    I did not do interim upgrades between 2.38 and 2.39.9, but only because I’ve been very busy and haven’t gotten around to it, and it was working so I was in no hurry. I was just doing routine maintenance today including upgrades.

    Plugin Author chrisvrichardson


    Older versions of the plugin didn’t require the wp_footer call.

    Do you still have the problem if you deactivate your other plugins and switch to the standard 2012 theme?

    If so, can you provide an example URL? (you’ll need to reactivate 2.39.9 first)

    Also, in case its helpful here’s a link to the FAQ:

    MapPress FAQ

    Hi Chris – I really do appreciate your help, and I had already checked your FAQ page before posting here…..unfortunately it’s a live site that generates revenue so I really can’t mess around with deactivating other plugins (I only use those that are absolutely necessary) or changing the theme to the default WP theme… it is I didn’t even have the plugin updated but 5 minutes when the client called me to complain that the maps weren’t showing….sigh….

    But I’ll set up a test installation and mess around with it there and post back my results in a few days.


    Per my previous posts, I have tried deactivating my plug-ins, and switching themes. Both pre-2.39 and post-2.39 releases of MapPress work fine with either version of .js (even the old one) on the newest build of WordPress, using the new 2012 theme. No post-2.39 versions of MapPress work with my current theme, on the newest WP build, regardless of which .js version I call. And yes my theme also has the wp_footer() call as specified. So in my case it doesn’t seem to be a .js problem, or a plug-in conflict, or a WP issue. It’s a conflict between my theme and ANY version of MapPress after the 2.39 release. My theme didn’t change, so it would seem something fundamental changed in the MP 2.39 release…???

    Plugin Author chrisvrichardson



    You do have an issue I’ve never seen before (a black map with working markers), so it probably is a conflict with your theme.

    I downloaded your original pages and replaced the old jQuery with 1.8.3. That seemed to work for me, but apparently not on your site.

    If you’d like me to trace it again please reactivate MapPress 2.39.9 on the URL you provided.

    Thanks Chris – I’ve updated to 2.40 and the problem still remains.

    Here’s the site:

    Plugin Author chrisvrichardson


    Hi @klynam,

    This script is redefining the javascript indexOf function for arrays:


    That interferes with jQuery’s inArray function, which is needed by MapPress:

    You can try updating that script to its current version, I think it’s 0.4.9. See here:

    Thank you – that seems to have fixed the issue.

    Shalom Yatza!

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Maps Wont Display’ is closed to new replies.