WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Maps no longer working – always showing latest post

[Resolved] Maps no longer working – always showing latest post

  • Just noticed that my map on the category pages that are suppose to show markers of posts only within that category is no longer working.

    Single maps and global maps are behaving the same way with zooming on my latest post.

    The behavior now seem to always be showing the marker of the latest post.

    The code on my category page is:

    <?php echo GeoMashup::map( ‘map_content=global&map_cat=’ . $cat->term_id ); ?>

    Can anyone advice me on how to fix this issue.

    Thanks, Jaime

    http://wordpress.org/extend/plugins/geo-mashup/

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Dylan Kuhn

    @cyberhobo

    If you use W3 Total Cache, there’s an incompatibility. See here for more:

    https://code.google.com/p/wordpress-geo-mashup/issues/detail?id=425

    Plugin Author Dylan Kuhn

    @cyberhobo

    BTW, the workaround is to disable the object cache.

    Hi Dylan thanks for the response and help! I deactivated w3 total cache and it seems to be working now! However the object cache was never enabled in the first place, so does that mean that w3 total cache and geo mashup can’t work at the same time?

    Plugin Author Dylan Kuhn

    @cyberhobo

    In the cases I’ve been able to look at, it’s always had the object cache option enabled and set to “Disk”, which I think is the default setting. The problem is that WordPress transients no longer work with that setting, at least on some systems. All the other caching options have worked fine on the installations I’ve seen.

    The latest Geo Mashup release, 1.5rc4, will cough up an error message in maps if transients aren’t working. You could use that to experiment with different W3TC configurations to see if you can find one that works. Let us know what you find!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Resolved] Maps no longer working – always showing latest post’ is closed to new replies.