Support » Plugin: WP Google Maps » Maps API Error

  • Resolved valeriatorre

    (@valeriatorre)


    Hi!
    My map doesn’t work anymore, and when I try to edit it this is the message I get:

    Maps API Error

    One or more error(s) have occured attempting to initialize the Maps API:

    This API project is not authorized to use this API
    Documentazione del Localizzatore di Negozi

    Can you please help me?
    Thank you,

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author perryrylance

    (@perryrylance)

    Hi Valeria

    Thank you for getting in touch!

    You need to activate all the relevant APIs through your Google API Dashboard

    In the very least, you will need the Google Maps JavaScript API, Places API and Geocoding API.

    Please see here for full documentation

    https://www.wpgmaps.com/documentation/creating-a-google-maps-api-key/

    I hope that helps?

    Kind regards
    – Perry

    valeriatorre

    (@valeriatorre)

    Thank you!
    Done, but it stil doesn’t work.

    Clare12345

    (@clare12345)

    I got the same error. Doesn’t the API key cost money through Google? Is there a free Google Maps option anymore? Thanks ahead of time.

    Plugin Author perryrylance

    (@perryrylance)

    Hi there

    Valeria, I visited the map page you had previously linked us to however all I see is a 404 page, can you please link us to your map page so I can see the issue?

    Clare, Google do require that you set up billing in order to use the Maps API now, however, you can set up your quota limits so that you never exceed the free quota they offer. You do, however, still need to set in credit card details, even if you set your limits up in such a way that no money changes hands.

    I hope that helps?

    Kind regards
    – Perry

    Thank you.

    1) the map is not online because I have disabled the plugin since I receive a terrible and very disturbing pop up with the error, EVERY time I load a page on the website (when I am logged in WordPress).
    Now is online again http://valeriaglutenfree.com/mappa-dei-locali/

    2) I have already setted the billing, followed the guide and nothing happens.

    Plugin Author perryrylance

    (@perryrylance)

    Hi Valeria

    I still see a 404 page there, however I can almost certainly guarantee that if you are seeing the “API not enabled” popup, you need to go to your API dashboard and enable the Javascript API, Places API and Geocoding API. Failing to do so would mean you would see that popup whenever you load the map or click the address field.

    Assuming you have set up billing correctly, enabling the relevant APIs will solve this issue.

    If any issues persist can you please give us access to the maps page so we can take a look?

    Kind regards
    – Perry

    How can I give you access?

    Plugin Author perryrylance

    (@perryrylance)

    Hi Valeria

    Please open a ticket so we can correspond privately.

    Please see here for documentation on adding a support agent to your Google account.

    Lastly, please see this documentation on how to enable the relevant APIs.

    I hope that helps?

    Kind regards
    – Perry

    Done.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Maps API Error’ is closed to new replies.