Support » Plugin: Simple Real Estate Pack » Map working on local server, not on live site

  • I have the Simple Real Estate Pack version installed on a local dev server and then on a live site. Unfortunately I cannot provide a URL as of yet…but I can explain the issue in fine detail.

    On my local server, the Google map loads schools, stores, etc perfectly. However, once I take my site and upload it the live server, the map still loads with the property shown in the right spot, but when a click on a school, etc checkbox happens, it just sits there spinning and never loads.

    I checked the http://mysite/wp-admin/admin-ajax.php response and it either 500 errors out OR returns 0.

    I’ve even tried adding a completely new location to make sure it wasn’t a URL issue (I did migrate everything, but I use a script that updates the URLs throughout the database perfectly).

    This is very strange because on my local server it always works and I’m testing the same address. Do you have any idea what could be happening? Thanks in advance 🙂

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Max Chirkov


    Nothing specific comes to mind… what version of PHP do you have on the live server? It has to be at least 5.2.

    Also, have you tried disabling and re-activating plugins just to make sure?

    Google Chrome or Firefox with Firebug should show JS errors if there are any…

    Is your production version on a sub-domain? I’ve seen some weird stuff when wordpress was hosted on a wp-specific hosting service where they deploy new installs on a sub-domain, but then assign a domain name to it… kinda like – in that case I’ve seen the plugin to fail.

    Hi Maxchirkov,

    Thanks for responding! I think I may have figured out why it’s not working or partially why. It seems the server I’ve been given is attempting to load the map via an Ajax call that is using:
    Server Microsoft-IIS/7.0
    X-Powered-By ASP.NET

    I uploaded the same exact site to a different staging server (this one was even on a sub-domain) that uses:

    I found this info via Firebug using the console, viewing the post request headers once a school, restuarant, bank, etc was checked on the map.

    If this isnt the problem then I imagine it is exacerbating it. Anyway, I’m trying to convince my client to update their host settings or switch to something other than GoDadday.

    Thanks for your help!

    Plugin Author Max Chirkov


    That’s interesting… Everything is loading via AJAX calls by default. You can change that in the SREP settings, but the map will still be loaded via AJAX since that’s how Google API is functioning (I think).

    I have no experience with Windows/.NET hosting services whatsoever… neither I host anything with Go Daddy except managing some old-old domains. You probably could get something as simple as Blue Host or Dreamhost which runs about $7-$8 a month.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Map working on local server, not on live site’ is closed to new replies.