Support » Plugin: Events Manager » Map Unavailable on Event Pages

  • Resolved sc456a

    (@sc456a)


    I know this is a common error. Here’s what I’ve done to troubleshoot:

    • Everything is up to date.
    • Disabled all other plugins.
    • Switched to default 2016 theme.
    • Followed instructions here and triple-checked. Set API key to None for Restrictions. API key works fine with the theme (Divi) to display maps. Tried creating a new key.

    None of that worked. Here’s a staging site where you can see the issue with no other plugins active and the 2016 theme enabled. Please advise. Thanks!

Viewing 10 replies - 16 through 25 (of 25 total)
  • I would love an answer to this as well. We’ve got the plugin setup on several sites and will have to find an alternative if the maps won’t load.

    This is not an API error. With API errors, the map will never – not even briefly.

    You have a number of JS errors showing, that’s almost certainly the problem. It seemed to me, though it may just be coincidence, that the map disappeared when the chat window appeared.

    It’s possible this is a conflict caused by your theme or another plugin. To check if it is, can you test with all other plugins deactivated and while running the default WordPress theme?

    Please see my original post. There are no console errors. I’m using the default WP theme and no plugins are active.

    This question has been open for over two weeks and zero progress has been made. Others are having the same issue and you haven’t provided any troubleshooting steps for anyone. You’ve asked us to disable plugins/themes several times despite my having done that already and stating as much in the original post.

    I’ve gone to a lot of effort, including the creation of a staging site, to help resolve this issue. I think we’d all appreciate a little more effort on your part.

    I’ve also this problem. I’ve deleted all refferers in the api-key once. Now at least the map was displayed – no more “Oops…”. Maybe you can also try it. This makes it possible to rule out an error in the Refferers. After that I tried again refferers. It works now, if I only the domain name enter without “http: //” without slashes and without stars. But no addresses are found in all configurations. The card remains blue. When creating the api-key I’ve activated all 3 libraries. I tried it on the site with additional arguments for the coordinates – all to no avail. The console displays: Google Maps API warning: RetiredVersion https://developers.google.com/maps/documentation/javascript/error-messages#retired-version util.js (210,12). But this warning is supposed to cause no problems.
    Who can help?

    Here you can see how my maps look: http://hahnemannzentrum-meissen.de/veranstaltungen-kurse-projekte/orte/stadtbibliothek-meissen/

    Plugin Author Marcus

    (@netweblogic)

    Hi Everyone,

    Unfortunately, Google has not made things easy for anyone with the new requirement for an API key. 99% of the cases is due to this not being set up correctly.

    The retired version warning should not prevent the map from working and is something we’ll fix in the next update. For example, I see a working map for you @marwo, but for @callerpatty you have an API settings issue which would be fixed by trying something like @marwo suggested in the reply above mine:

    Google Maps API error: ExpiredKeyMapError

    This is definitely a problem with the API keys, and the only other reason you may be experiencing this issue is because you may have another plugin or theme installed which loads the Google Maps library before we do and don’t request an API Key or you’ve supplied a bad/expired API key to that theme/plugin setting.

    @sc456a I’ve subscribed to this issue and will keep an eye on it. If you’ve tested out the API key instructions and removed referrer restrictions and it STILL doesn’t work (as you say is the case), please post a link to your page again and I’ll take a look.

    mooberrydreams

    (@mooberrydreams)

    I know this is an old thread but of all the threads about maps not working, this one seems to have made the most progress/response.

    I am having the same problem as others have reported. Made multiple APIs, etc. I’ve tried tracking down the code to see if I could figure out what was going wrong. Here’s what I found:

    When the map is displayed, two fields for latitude and longitude are checked and if they are 0, no map is displayed.

    On the locations page there are hidden fields for latitude and longitude, and they are empty. I modified the code to display those fields, and then populated them with values.

    BAM, the map shows up.

    Whatever is supposed to be populating the latitude and longitude fields is what’s not working and that’s what’s causing the map to not show up.

    I hope this helps to get someone pointed in the right direction.

    mooberrydreams

    (@mooberrydreams)

    Update:
    The latitude and longitude fields DO update properly when the address fields are changed.

    It seems once there are non-0 numbers in those fields, it works fine. Even after reverting the code back, new locations are displaying maps. Perhaps it’s something to do with a new install of the plugin and an update somewhere along the way had the fields defaulting to 0 or something?? (I just installed and activated yesterday)

    caimin_nwl

    (@caimin_nwl)

    @mooberrydreams To save confusion, can you open a new thread for issue? It doesn’t sound like it’s related to the Google Maps API. Thanks.

    mooberrydreams

    (@mooberrydreams)

    Well, yes, that’s my point. It’s not a problem with the API. I was having the same issue as these several other users with unresolved threads about the Google Maps not working. I did all the suggestions given just like the other users did, and they did not fix the issue. { new API, default theme, no plugins, etc. }

    The response has continued to be it’s a problem with the API key or a plugin or theme conflict. But that wasn’t the cause of the issue.

    I now have this working, using the same API key I had when it wasn’t working, with a not-default theme, and many other plugins installed. The only thing that worked to get the maps to actually show up was to get those two fields initially populated with a value other than zero.

    My site is working now. I don’t need a new thread about it. I posted my findings to help others and hopefully shed light on the issue so that it may be fixed.

    Plugin Author Marcus

    (@netweblogic)

    For posterity, I’ll reply here but I’d suggest readers to open up a new thread, letting us know that they’ve carefully read & followed our docs about setting up a google maps API key and reference this thread if necessary.

    Having seen enough misconfigurations with API keys, I can probably guess that you at one point did not have valid API keys (or ones that had all the related API libraries active), or maybe just had maps disabled, and that prevented long/lat values from being stored.

    The problem is then when things are working, you have a 0/0 coordinate that we assume is an invalid/non-existent coordinate.

    To get things working, you need to change the address in any way, and then back again, things will refresh themselves. We’re going to fix that so in the future you just resave the location and things get corrected.

Viewing 10 replies - 16 through 25 (of 25 total)
  • You must be logged in to reply to this topic.