Support » Plugin: Events Manager » Map Unavailable / Location not found

  • Resolved julsd

    (@julsd)


    Have been through all of your instructions and documentation, ensured billing is set up, checked I have the correct information entered etc. but cannot get the maps working on any event

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 16 total)
  • Plugin Support angelo_nwl

    (@angelo_nwl)

    hi,

    just to confirm, did you already follow the step by step instructions from this tutorial – https://wp-events-plugin.com/documentation/google-maps/api-key/ ?

    I am having the same problem. I entered the api key. I got JavaScript console errors before I entered the key, but am getting no console errors or messages now.

    On the Location edit page (in the admin UI), I only see text that says “Location not found”. It is the below HTML structure:
    div#em-location-map-container
    div#em-map-404.em-location-map-404
    p Location not found
    div#em-map.em-location-map-content

    There is a map inside the div#em-map.em-location-map-content. So the map is there, but the address fields are not being fed to the map for some reason. I have tried multiple addresses and get the same result.

    On the event page (live site page – /event/event-name), I see “Map Unavailable” in the below HTML structure:
    div.entry-content
    div
    I Map Unavailable

    There is no hidden map on this page.

    Hi
    To confirm I have done all of the following
    1.Enabled Geocoding API, Maps Embed API, Maps Javascript API, Maps Static API, Places API
    2.Generated Credentials and added the API to your Event Manager settings
    3.Made the Key unrestricted to troubleshoot the problem
    4.Verified the domains that you want to use the key on
    It is still not working …

    Plugin Support angelo_nwl

    (@angelo_nwl)

    just to narrow down the problem and help us debug the issue is it possible to try the following temporarily:

    – deactivating all other plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the default theme to rule out any theme-specific problems

    The steps you shared above seems correct and we can’t replicate this issue on our test servers.

    I have to say I have the same issue I’ve stripped everything down so I am only running an unmodified Twenty Seventeen theme and the only active plugin is Events Manager, I’ve got a brand new api from google with no restrictions since it’s on a local host and it does not work (I know it used to work) Bizarrely I have it working fine on a live site with no issues and that has a stupid number of plugins running, I even tried using that api with the site that is on a local host with no difference it doesn’t work

    I have no problems whatsoever on my live blogs, but Google Maps API never worked on a localhost, as far as I know. It doesn’t work on mine anyway.
    You have to set your domain names in the Google API settings and it just does not accept “localhost”.

    I’m having the same issue, similar at least. The API keys have been entered, unrestricted, the console shows

    Google Maps JavaScript API warning: NoApiKeys https://developers.google.com/maps/documentation/javascript/error-messages#no-api-keys

    Yet I have them all set. According to that error, that’s an issue with the plugin, not the API key setup.

    I followed the API guide to a T.
    Made sure I wasn’t hitting page cache as well.

    Hi Mr Jeff Paul,
    If you are looking for an easy and working alternative, please check out my replacement with OpenStreetMaps. 😉

    https://wordpress.org/plugins/stonehenge-em-osm/

    That worked flawlessly Patrick, Gratzi!

    You are very welcome, Jeff 😀

    Jay Collier

    (@jcollier)

    I am using this, too, since I have followed all instructions and have not been successful in getting Google Maps to work.

    Stonehenge Creations

    (@duisterdenhaag)

    Thanks, Jay! 🙂
    You know, the strange thing is that I personally never had any problems with Google Maps on any of my MultiSite blogs. Well, until Google changed its controls, that is 😉 Technically it works straight away on my installations.

    But since Google started gathering billing info, I was angry. And seeing so many questions of people not being able to use Google Maps, I decided to create an alternative.

    Glad you like it!!! 😀

    I had a horrid time getting it working so am just re-posting my solution to some of the threads I found, in case this helps. In Events Manager I simply choose EMBEDDED maps because it’s all charities and they can’t afford to pay for maps.

    Google Cloud Console -> API -> new project -> name the project etc…
    APIs to enable:
    Maps Javascript
    Geocoding
    Maps Embed
    (at least that’s all I needed)

    App restrictions (HTTP)
    Include:
    https://mywebsite.com/*
    https://*.mywebsite.com/
    mywebsite.com
    *.mywebsite.com
    (plus any you may specifically need – e.g. with www)

    Create a billing account. My set-up didn’t work until I opted for a NEW billing acc, as a business – and included address etc.
    LINK THE BILLING ACCOUNT
    Just making it is only step one. Select your project from the top drop-down, then BILLING from the left. You should get a pop-up asking to connect to an account.
    If you don’t link it, your maps may not work.

    Now create a new location in EM, make it one you know works in google maps (I used my home). For me it worked, however, I still had to go to the old ‘broken’ locations and retype the first line before it would refresh and the location magically gain a map.)

    Hope this helps anyone equally frustrated!

    Or just use the very easy and 100% free replacement:
    https://wordpress.org/plugins/stonehenge-em-osm/

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Map Unavailable / Location not found’ is closed to new replies.