Support » Plugin: Events Manager » Map Unavailable

  • Hi on all of the events I’ve posted it says Map Unavailable
    I think I did everything correctly, but I am not sure why the maps aren’t showing up on the event pages. please help. I disabled all the plugins and still didn’t work. I tried all suggestions on the help forum, nothing. Thanks.

    The page I need help with: [log in to see the link]

Viewing 9 replies - 16 through 24 (of 24 total)
  • Delete the menu option
    History of Vegan (this has the problem we are talking about).

    Those files in the Must Use directory… are inserted by a plugin.
    They are not dependent on CORE WordPress.

    I don’t exactly think they are a problem… but we are hacking out anything.

    Do not delete them…
    But… you could simply just rename those files… with an “X” or something..

    NOT SURE about sso.php…. did a quick look up and looks like a login thingy.. Jetpack maybe.. so don’t mess with that one.

    the “endurance” type file is obviously some sort of cache (makes your site faster)…

    The files you have in the Must Use directory were not what I was looking for..
    But I have seen other “cache” -> endurance throw a wrench in the works.

    Delete that Menu option I mentioned first.. and make sure it isn’t being called without the https as the rest of your site..

    Also the cache program you are using… help to clear it out and or disable it.
    Marking those files with an “X” would do it..

    • This reply was modified 4 years, 4 months ago by Robswaimea.
    Thread Starter Michael Lanfield

    (@michaellanfield)

    The strange thing is, I did not implement this new menu until recently and I was having trouble with the google map not displaying before.

    I saw you just came back.. read above.. you may have missed it..

    Thread Starter Michael Lanfield

    (@michaellanfield)

    I have Wordfence Security and WP-Optimize. No jetpack.

    Wordfence won’t be the problem… I have it on all my sites…

    Well you are learning stuff along the way.. although I am sure painful as it is..

    Delete the menu option
    History of Vegan (this has the image problem we mentioned above).
    just for now to keep things error(less).

    Your API key is not throwing any errors…
    But it might be something at the Google API that you have setup..

    • This reply was modified 4 years, 4 months ago by Robswaimea.
    • This reply was modified 4 years, 4 months ago by Robswaimea.

    Make sure the WP-Optimize is not cacheing stuff…
    figure out how to delete the cache… deactivate…

    I keep seeing this stuff… Delete the menu option

    History of Vegan (this has the image problem we mentioned above).

    • This reply was modified 4 years, 4 months ago by Robswaimea.
    Thread Starter Michael Lanfield

    (@michaellanfield)

    I fixed the images and it going to the proper urls. Thanks. That I figured out. How do I fix the Google API? I am stuck here. Google is confusing. I deactivated WP-Optimize.

    I am bring this over from the other thread you had to be on topic..
    @caimin asked…
    Are maps displaying in admin?

    When you make an event… do you see the map when you put the info at the “Locations” form fields ?
    Or.. when you view the event… when you are logged in to the website do you see the map ?

    Yes.. Google API has gotten more confusing…
    I’ll repeat myself in this thread..
    ————————————
    So make sure you have the basics as below…
    — Under the Menu (‘hamburger three dashed lines–>click”)
    API’s Services —> Dashboard
    on the bottom of the page you should have the following API’s
    (that you enabled from the “Library –> Maps”)

    In your “Dashboard”
    API
    Google Maps JavaScript API
    Google Maps Geocoding API
    Google Places API Web Service

    On your Credentials.. make sure you have “ticked”
    HTTP referrers (web sites)

    and your HTTP referrers should look like this..
    *yourwebsite.com/*
    —————————-
    What do you have for this…

    and your HTTP referrers should look like this..
    *yourwebsite.com/*
    Thread Starter Michael Lanfield

    (@michaellanfield)

    Hi Robswaimea. Thank you for all your help and patients. I think I might have missed the last part adding my website in HTTP, but I thought I did it. Also I did not add in the events, my friend who is helping me adding content to the site did. I will check if all working now after adding in my url.

Viewing 9 replies - 16 through 24 (of 24 total)
  • The topic ‘Map Unavailable’ is closed to new replies.