Support » Plugin: Events Manager » Map Unavailable

  • Hi on all of the events I’ve posted it says Map Unavailable
    I think I did everything correctly, but I am not sure why the maps aren’t showing up on the event pages. please help. I disabled all the plugins and still didn’t work. I tried all suggestions on the help forum, nothing. Thanks.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 24 total)
  • I am not part of support just some dude…

    Using Firefox Inspector (right click on any page… drop down menu click “Inspect Element(Q))… Click -> Console -> JS —->tick off the Errors, and Warnings.
    there is also the same similar procedure for Chrome and IE.

    anyway… I am seeing these errors…
    “unreachable code after return statement[Learn More] js:69:1092
    HTTP load failed with status 404. Load of media resource https://www.thosecrazyvegans.net/%E2%80%9Dhttps://www.thosecrazyvegans.net/wp-content/uploads/2017/11/official_website.mp3%E2%80%B3 failed.”

    Which doesn’t exactly point to a situation with the Map not showing.

    You didn’t mention above if you tried a generic Theme.. like Twenty Seventeen (WordPress Official Release Theme)
    To test…
    That is… could be a Theme issue.

    and or read this recent thread..
    https://wordpress.org/support/topic/map-not-showing-33/

    hang in there… hope you can work out that deportation issue.

    • This reply was modified 4 years, 4 months ago by Robswaimea.
    • This reply was modified 4 years, 4 months ago by Robswaimea.
    • This reply was modified 4 years, 4 months ago by Robswaimea.

    Also not part of support – but had a similar issue when first setting up the Google Map – it had nothing to do with WordPress or the plugin – had similar error messages as shown by Robswaimea. Turned out it was an issue with the Google Map end not being set up properly – since they changed their system, it has been a nightmare to sort out and I ended up by getting a tech friend to do it for me so can’t even advise you on what to do – but I would start there.

    It never ceases to amaze me how Gxxgle takes a basic operation and obfuscates in a “new” presentation with multiple pages, and blah blah blah…

    The basic procedure and presentation with pictures is here..
    http://wp-events-plugin.com/documentation/google-maps/api-key/

    But as mentioned Gxxgle “brain-masters” makes it more confusing..

    So make sure you have the basics as below…
    — Under the Menu (‘hamburger three dashed lines–>click”)
    API’s Services —> Dashboard
    on the bottom of the page you should have the following API’s
    (that you enabled from the “Library –> Maps”)

    In your “Dashboard”
    API
    Google Maps JavaScript API
    Google Maps Geocoding API
    Google Places API Web Service

    On your Credentials.. make sure you have “ticked”
    HTTP referrers (web sites)

    and your HTTP referrers should look like this..
    *yourwebsite.com/*

    Plugin Support caimin_nwl

    (@caimin_nwl)

    @michaellanfield Let us know if the suggestions by @robswaimea and @vocalist haven’t helped fix the problem.

    Hello, I tried all the suggestions above, and I still have “Map unavalaible”.

    Plugin Support caimin_nwl

    (@caimin_nwl)

    @abracarambar Can you open a new thread for your question, with a link to your site? Thanks.

    Well, I don’t know if same issue, but in my case, I tried to register a location and always displays “Location not found”. I tried with very common addresses but same advice appears. This in dashboard, in frontend the legend is “Map unavalaible”
    Thanks!

    Using the inspector console, I saw my errors, and I solved all. I can see the maps now. Thanks.

    Thread Starter Michael Lanfield

    (@michaellanfield)

    It seems like I did everything correctly. I went again through all the steps and still no luck for the maps to display.

    Plugin Support caimin_nwl

    (@caimin_nwl)

    It’s possible this is a conflict caused by your theme or another plugin. To check if it is, can you test with all other plugins deactivated and while running the default WordPress theme?

    Thread Starter Michael Lanfield

    (@michaellanfield)

    I disabled all my plugins and switched my theme to 2017 and still did not work.

    Plugin Support caimin_nwl

    (@caimin_nwl)

    It’s possible there’s a problem caused by the insecure content error on your site.

    If you go here…
    https://www.thosecrazyvegans.net/events/world-peace-diet-sunday-2018-04-29/
    …and open the inspector console in your browser you’ll see it.

    Using the “inspector” what @caimin is talking about is under the tab Security.

    What @caimin is tell us is this image was uploaded.. or in the directory and being called without the “s” in https
    http://www.thosecrazyvegans.net/wp-content/uploads/2018/04/Donald-Watson.jpg

    I notice when I hover over the menu option “Vegan” the drop down show me
    About
    History of Vegan (this has the problem we are talking about).

    and thusly the “links” are not working…
    which I guess this is “underdevelopment” Menu option…

    So… if @camimin has figured it out (I hope so !!!!)
    try deleting the Menu option to “History of Vegan” which would be associated with the image file… that is being called throwing the error @caimin mentioned.

    Also… just out of curiosity… there is something called,
    Must Use Plugins…
    Using an FTP program… do you have anything in this directory…
    yourwebsite/wp-content/mu-plugins

    Hope you get this sorted out..
    just some dude…

    • This reply was modified 4 years, 3 months ago by Robswaimea.
    Thread Starter Michael Lanfield

    (@michaellanfield)

    Hi. The menu is under development. Yes, the mu-plugins folder I am not sure what that is.

    It has these 3 files within it. Should I delete them?

    endurance-browser-cache.php
    endurance-php-edge.php
    sso.php

    Update, I found out these are necessary
    https://codex.wordpress.org/Must_Use_Plugins

    Thread Starter Michael Lanfield

    (@michaellanfield)

    caimin_nwl how do I fix it?

Viewing 15 replies - 1 through 15 (of 24 total)
  • The topic ‘Map Unavailable’ is closed to new replies.